Support » Installing WordPress » errno=13 and the dreaded blank page

  • Resolved klanxner


    Hi. Installation seemed to go OK as far as setting up the admin area. But on the same page congratulating me for a successful install, I got an error message I’ve seen elsewhere on this forum:

    Warning: is_dir(): Stat failed for /usr/www/users/klanxner/gavinjournal/wordpress/wp-content/themes/gavin-blog (errno=13 – Permission denied) in /usr/www/users/klanxner/gavinjournal/wordpress/wp-admin/upgrade-functions.php on line 673

    The install is on an Apache server. All permissions of files and folders (checked and doublechecked) are currently set to 777 just to get through this. It appears to be trying to write a folder within the themes folder and can’t. Never any permissions problems on this server previously. Apparently all admin files and the DB can be created and written to.

    The result is that the blog page is completely blank. Others have reported a page with only the html, head, and body tags. In my case, a view source of the blank page is also blank. Nothing at all.

    This is a brand new install, presumaby using the default theme. No add-ons or plug-ins. Everything else appears to work in the admin area. I can add new posts, edit previous ones, etc. The Presentation area lacks some information, presumably becausse it is unable to read the themes directory. Thus it says, “The template files are located in . The stylesheet files are located in .”

    I’ve been searching and reading here and via Google for a couple of days. Read every relevant post about blank pages and errno-13. No solutions seem to be pertinent and I am at a loss to figure this out.

    Thanks for any guidance.


Viewing 7 replies - 1 through 7 (of 7 total)
  • “It appears to be trying to write a folder within the themes folder and can’t.”
    Yep – that’s exactly what it is trying to do.

    Try deleting everything in /themes and uploading a new default and another theme. See if you can get the presentation area to work properly ?

    Thanks for the help. But still the same. On another attempt, I even tried manually creating the folder that WP wasn’t able to write. No go.

    This week I’ve run into seemingly unsolvable problems with phpBB, punBB, and now here. 🙂


    In that case, who is your host ?

    Sounds like your host is doing something funky as if you had everything set to 777 then you shouldn’t get that error.

    Can you setup a phpinfo.php for us to look at?


    The host is pair Networks. I think they are generally considered to be one of the best at what they do.

    Here’s a phpinfo in the blog’s root directory:

    Thanks for the help!


    That all looks above board, maybe ask your host if there is something on their setup that could be affecting it?

    Thank you for your help. The blog is now working.

    After 3 reinstalls, the 3rd one finally stuck. In the process, I discovered that if I ran into any permissions problems during installation, and I fixed those problems and then ran install.php again, I was always blocked from writing that crucial folder to /themes/.

    What eventually worked was a clean reinstall of WordPress with correct permissions to begin with.


Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘errno=13 and the dreaded blank page’ is closed to new replies.