Support » Plugin: MANGOPAY WooCommerce » Erreur : L’API MANGOPAY a répondu : «Not found»

  • Resolved aminlam

    (@aminlam)


    Bonjour,
    Je viens de remarquer une erreur dans mon back-office WP.

    Là où normalement sont affichés les infos User ID/ Wallet ID … solde etc.

    J’ai ce message :

    Erreur : L’API MANGOPAY a répondu : «Not found»

    Aucun portefeuille MANGOPAY. Vérifiez que tous les champs obligatoires du profil utilisateur ont été renseignés.

    Pour tous mes utilisateurs, clients comme vendeurs.

    Pourtant les transferts se font bien lors des paiements.
    Et dans la liste des users wp, je vois bien “oui” dans la colonne “compte Mangopay”.
    (d’ailleurs les autres infos mangopay Adresse, type de compte, etc apparaissent bien…)

    WordPress 5.0.3
    WC Vendors Pro – 1.5.10
    WC Vendors Marketplace – 2.1.4
    Woocommerce 3.5.4
    MANGOPAY – 2.9.1

    Merci pour votre aide
    Amin

Viewing 15 replies - 1 through 15 (of 27 total)
  • Plugin Author Yann at WP&Co

    (@ydubois)

    Bonjour

    Pouvez vous préciser les points suivants:

    – Confirmer que vous êtes dans l’écran d’édition d’un utilisateur dans le back-office de WordPress (Utilisateurs > Tous les utilisateurs > Clic sur un utilisateur, URL commençant par wp-admin/user-edit.php?user_id=...)
    – Confirmer que vous êtes dans cet écran au niveau où il est indiqué à gauche “Infos MANGOPAY
    – Si c’est bien le cas, vous devez avoir à droite 2 liens directs vers le dashboard MANGOPAY:
    – Voir l’utilisateur (N°xxx) dans le tableau de bord MANGOPAY
    – Accès aux transactions MANGOPAY de l’utilisateur
    …ces liens sont-ils bien présents?
    – Que se passe-t-il si vous cliquez sur chacun de ces liens?
    – Le numéro d’utilisateur (User) MANGOPAY indiqué dans le premier lien (N°xxx) correspond-il à un des utilisateurs que vous retrouvez en vous connectant à votre dashboard MANGOPAY dans la liste des utilisateurs (colonne ID)?
    – Est-ce que vous disposez de plusieurs comptes MANGOPAY, et est-il possible que vous ayez par erreur connecté votre marketplace avec un identifiant MANGOPAY d’un autre compte?

    Bien cordialement

    Thread Starter aminlam

    (@aminlam)

    Oui exactement je suis à cet endroit.

    Les liens dont vous parlez été présents (et fonctionnels) la dernière fois que j’en ai eu besoin…

    Mais aujourd’hui voici ce que je vois :
    https://www.dropbox.com/s/uyx6hwczaojgx9b/bugmangopay.png?dl=0

    Thread Starter aminlam

    (@aminlam)

    Je viens de voir ce message dans l’onglet de config mangopay :
    https://www.dropbox.com/s/tflddgpnpod9aiw/bug2.png?dl=0

    Thread Starter aminlam

    (@aminlam)

    En fait c’est plus grave que ce que je pensais, la commande est impossible :
    J’ai ce message d’erreur :
    https://www.dropbox.com/s/96latq1cgyxz8ku/bug3.png?dl=0

    La dernière commande payante (car il y a aussi des produits gratuits sur le site) date d’hier à 16h…
    je n’ai pas fait de MAJ depuis.

    J’ai juste fait la MAJ du plugin mangopay ce matin quand j’ai constaté ce bug…

    là c’est critique en effet

    Plugin Author Yann at WP&Co

    (@ydubois)

    Votre marketplace ne se connecte plus à l’API MANGOPAY : revérifiez bien votre ID client et votre clé d’API dans le menu d’administration MANGOPAY.

    Vérifiez que votre compte MANGOPAY est toujours actif en vous connectant à votre dashboard MANGOPAY: https://dashboard.mangopay.com/Authorize/SignIn

    Si c’est le cas, vérifiez avec votre hébergeur si rien n’a changé au niveau de votre hébergement qui interdirait désormais les connexions de votre serveur avec l’API REST MANGOPAY (nouveau firewall ?).

    Après avoir vérifié tous ces points, vous pouvez contacter directement le support client MANGOPAY (même s’ils sont à l’écoute de ce forum, ils auront besoin d’informations qu’on ne peut pas partager ici pour vous aider).

    https://support.mangopay.com/s/?language=fr

    Thread Starter aminlam

    (@aminlam)

    Je viens de faire plusieurs tests…

    Même en désactivant tous les plugins la connexion ne fonctionne pas.
    (ni en sandbox ni en prod)
    Mes ID fonctionnent car je viens de les tester sur un autre site de test…

    je vais contacter le support et l’hébergeur 🙂

    Thread Starter aminlam

    (@aminlam)

    ça ne peut pas être mangopay qui bloque l’ip de mon serveur par exemple ?

    C’est 109.234.xxx.xxx

    Merci pour votre aide

    • This reply was modified 2 years, 7 months ago by aminlam.
    Plugin Author Yann at WP&Co

    (@ydubois)

    Non, MANGOPAY ne bloque pas le fonctionnement des applications de ses clients 🙂

    Ne donnez pas d’adresses IP ni d’informations personnelles ici, veuillez contacter directement le support MANGOPAY pour cela (je vous ai donné le lien ci-dessus)

    Le plus probable est que c’est au niveau de votre hébergement que cela bloque, il faut demander à votre hébergeur d’autoriser les appels en http vers l’api MANGOPAY : api.mangopay.com et surtout de vérifier que le PHP de votre serveur arrive à s’y connecter.

    Thread Starter aminlam

    (@aminlam)

    J’ai contacté l’hébergeur.
    J’espère trouver une solution rapidement

    Thread Starter aminlam

    (@aminlam)

    Voici ce que me demande mon hébergeur :
    – – –

    Pouvez-vous contacter votre prestataire que vous utilisez pour lui demander les informations suivantes ?

    – Version de CURL à utiliser
    – Version de PHP à utiliser
    – Adresse IP de leurs services API.

    Je ne constate pas de blocage au niveau du serveur et une 404 indiquerait une page non trouvé.
    – – – –

    Merci pour votre aide

    Plugin Author Yann at WP&Co

    (@ydubois)

    L’utilisation du plugin WooCommerce-MANGOPAY ne demande rien de particulier sur un environnement d’hébergement standard contemporain adapté à WordPress.
    – PHP version 5 ou supérieure
    – Bibliothèque php-curl adaptée à la version de PHP utilisée
    – L’adresse IP est celle de l’API déjà indiquée : api.mangopay.com

    Une erreur 404 lors du test de connexion indique prioritairement un identifiant client MANGOPAY erroné, donc c’est la première chose à vérifier quitte à l’effacer et à le re-saisir.

    Si l’identifiant client est correct, d’autres clients ont déjà rencontré des erreurs 404 à cause de problèmes de connexions sortantes depuis leur serveur d’hébergement.

    Thread Starter aminlam

    (@aminlam)

    Bonjour,

    Je viens de migrer l’ensemble de mon site sur mon serveur de test chez un autre hébergeur :
    – Connexion impossible.

    Etant donné que les commandes ont cessée le 19 février à 16h… j’ai restauré la sauvegarde BDD du 19 à 3h00
    Et là, la connexion se fait !

    Mais du coup, je ne peux pas faire ça sur mon serveur de prod au risque de perdre 2 jours d’historique.

    Ce n’est pas un soucis de fichiers car je n’ai rien changé mais un soucis quelque part dans la base de donnée… je vais essayer de comparer chaque plugin activé ou pas… mais ça reste un mystère.

    Plugin Author Yann at WP&Co

    (@ydubois)

    Ré-initialisez votre ID client MANGOPAY: commencez par l’effacer, enregistrez, puis re-saisissez-le. C’est probablement le stockage de cet identifiant qui a été corrompu dans votre base de données. C’est toujours le premier point à vérifier et re-vérifier comme déjà indiqué.

    Thread Starter aminlam

    (@aminlam)

    J’ai essayé plusieurs fois.
    – Supprimer l’id / save / recopier
    – passage en sandbox / passage en prod

    C’est toujours le même message qui s’affiche.
    Je ne comprends pas ce qui a pu provoquer ce bug puisque rien n’a changé sur le site (à part des produits soumis par les contributeurs)

    Thread Starter aminlam

    (@aminlam)

    Dans les logs WC j’ai ces messages là :

    
    2019-02-19T05:33:07+00:00 CRITICAL Uncaught MangoPay\Libraries\Exception: Unexpected response. Missing PersonType property in /home/******/public_html/wp-content/plugins/mangopay-woocommerce/sdk/MangoPay/ApiUsers.php:299
    Stack trace:
    #0 /home/******/public_html/wp-content/plugins/mangopay-woocommerce/sdk/MangoPay/ApiUsers.php(61): MangoPay\ApiUsers->GetUserResponse(Array)
    #1 /home/******/public_html/wp-content/plugins/mangopay-woocommerce/inc/mangopay.inc.php(1822): MangoPay\ApiUsers->Get('')
    #2 /home/******/public_html/wp-content/plugins/mangopay-woocommerce/inc/main.inc.php(477): mpAccess->get_mp_user('')
    #3 /home/******/public_html/wp-content/plugins/mangopay-woocommerce/inc/main.inc.php(414): mangopayWCMain->kyc_doc_upload_form_func(Array)
    #4 /home/******/public_html/wp-includes/class-wp-hook.php(286): mangopayWCMain->kyc_doc_upload_form_doaction('store-settings....', 'wc-vendors/dash...', '/home/******/...', Array)
    #5 /home/******/public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters('', Array)
    #6 /home/ed dans /home/******/public_html/wp-content/plugins/mangopay-woocommerce/sdk/MangoPay/ApiUsers.php à la ligne 299
    
    

    Mais ils y sont déjà dans les logs des jours précédents et ça fonctionnait avant…

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘Erreur : L’API MANGOPAY a répondu : «Not found»’ is closed to new replies.