Support » Fixing WordPress » ERR_TOO_MANY_REDIRECTS

  • Resolved JacobALund

    (@jacobalund)


    Hi
    I’m receiving this message on one of my websites when I try to enter it: ERR_TOO_MANY_REDIRECTS

    My site is http://www.bismv.dk

    The strange thing is that when I go to a sub-page such as http://www.bismv.dk/kontakt it works perfectly fine. Also, I can enter the control panel without problems.

    But I just can’t seem to be able to enter the site by it’s front-page. I’m not entirely sure when this issue started to happen, but it might have been in relation to the new version 4.4.1.

    Hope you can help!

Viewing 15 replies - 46 through 60 (of 60 total)
  • questions4wp

    (@questions4wordpress)

    Sure, very happy to help. I’m running the site (and several others, which are not affected) on a VPS with InMotion Hosting. I also have a non-VPS shared server with them, and none of the WordPress sites on that server have been affected.

    My .htaccess has that exact same text in it – previously there was a linebreak at the beginning, but then I deleted it and let WordPress re-generate it, and now it has that exact text with no linebreak. I doubt the linebreak has any actual bearing on the functionality, just thought I’d report all the details.

    Below is the dump from the Send System Info plugin – I’ve had to remove some of the identifying information, as this is a client’s site and they’d prefer not to have it posted on the forum – however, all of the technical information is the same. I’ve noted where I’ve removed any information. Hope this helps, please let me know if there’s anything else I can provide.

    Also, regarding the plugins listed, they’re all active at the moment, but aren’t all active during the normal use of the site. As I said in a previous post, disabling all of them doesn’t fix the issue.

    // Generated by the Send System Info Plugin //

    Multisite: No

    SITE_URL: http://MySite.com (REMOVED)
    HOME_URL: http://MySite.com (REMOVED)

    WordPress Version: 4.4.1
    Permalink Structure: /%category%/%postname%/
    Active Theme: Custom Theme for Client MySite.com (REMOVED)

    Registered Post Stati: publish, future, draft, pending, private, trash, auto-draft, inherit

    Platform: Windows
    Browser Name: Chrome
    Browser Version: 47.0.2526.106
    User Agent String: Mozilla/5.0 (Windows NT 10.0; WO
    W64) AppleWebKit/537.36 (KHTML,
    like Gecko) Chrome/47.0.2526.106
    Safari/537.36

    PHP Version: 5.4.33
    MySQL Version: 5.6.28
    Web Server Info: Apache

    WordPress Memory Limit: 40MB
    PHP Safe Mode: No
    PHP Memory Limit: 256M
    PHP Upload Max Size: 128M
    PHP Post Max Size: 128M
    PHP Upload Max Filesize: 128M
    PHP Time Limit: 30
    PHP Max Input Vars: 1000
    PHP Arg Separator: &
    PHP Allow URL File Open: Yes
    WP_DEBUG: Disabled

    WP Table Prefix: Length: 3 Status: Acceptable

    Show On Front: page
    Page On Front: Home (#5)
    Page For Posts: (#0)

    WP Remote Post: wp_remote_post() works

    Session: Disabled
    Session Name: PHPSESSID
    Cookie Path: /
    Save Path: /tmp
    Use Cookies: On
    Use Only Cookies: On

    DISPLAY ERRORS: On (1)
    FSOCKOPEN: Your server supports fsockopen.
    cURL: Your server supports cURL.
    SOAP Client: Your server has the SOAP Client enabled.
    SUHOSIN: Your server does not have SUHOSIN installed.

    ACTIVE PLUGINS:

    Akismet: 3.1.7
    Google Analytics by Yoast: 5.4.6
    Infinite Scroll: 2.6.2
    Insert PHP: 1.3
    Jetpack by WordPress.com: 3.8.2
    Require Post Category: 1.0.4
    Send System Info: 1.2
    SEO Redirection: 3.4
    Wordfence Security: 6.0.22
    Yoast SEO: 3.0.7

    @marius

    I tried adding the code in https://wordpress.org/support/topic/err_too_many_redirects-12/page/2?replies=35&view=all#post-7857847 to my functions.php file for my theme. The “too many redirects” error persists even with that new code in functions.php.

    I also know for sure the code was being used because I had a typo that first gave me an error until I fixed the typo.

    This is a new server so it’s running a fresh Apache2 and Php5. Here is the relevant system info of the failing server:

    // Generated by the Send System Info Plugin //
    
    Multisite:                No
    
    WordPress Version:        4.4
    Permalink Structure:      /%category%/%postname%/ 
    
    Registered Post Stati:    publish, future, draft, pending, private, trash, auto-draft, inherit
    
    PHP Version:              5.5.9-1ubuntu4.14
    MySQL Version:            5.5.46-0ubuntu0.14.04.2
    Web Server Info:          Apache/2.4.7 (Ubuntu)
    
    WordPress Memory Limit:   40MB
    PHP Safe Mode:            No
    PHP Memory Limit:         256M
    PHP Upload Max Size:      2M
    PHP Post Max Size:        8M
    PHP Upload Max Filesize:  2M
    PHP Time Limit:           30
    PHP Max Input Vars:       1000
    PHP Arg Separator:        &
    PHP Allow URL File Open:  Yes
    WP_DEBUG:                 Disabled
    
    WP Table Prefix:          Length: 3 Status: Acceptable
    
    Show On Front:            page
    Page On Front:            Home (#5)
    Page For Posts:            (#0)
    
    WP Remote Post:           wp_remote_post() works
    
    Session:                  Enabled
    Session Name:             PHPSESSID
    Cookie Path:              /
    Save Path:                /var/lib/php5
    Use Cookies:              On
    Use Only Cookies:         On
    
    DISPLAY ERRORS:           N/A
    FSOCKOPEN:                Your server supports fsockopen.
    cURL:                     Your server supports cURL.
    SOAP Client:              Your server has the SOAP Client enabled.
    SUHOSIN:                  Your server does not have SUHOSIN installed.

    The issue for me was an error for too many redirects only on my homepage. The solution I found was: go to Settings>Permalinks> then make sure everything is in lowercase.

    Thanks to @jmcgovern94, my homepage is working.

    I was getting the “Too many redirects” error only on my homepage, which was static, and I was using %postname% for permalinks.

    My Settings > General > WordPress Address (URL) was LinkedInToCollege.com, which had some caps.

    I changed it to lowercase and changed the permalinks back to %postname% (I had temporarily set to plain to get my homepage to function) and now it’s working.

    The code fix did not work for me either, I have 5 sites on the same hosting company different machines that all have this problem with 4.4.1, 1 has the homepage loop and the others all have the wp-admin loop.

    All my other sites on 4 4 0 that did not autoupdate are working fine.

    admin files are accesible using a direct path only wp-admin/post.php

    /wp-admin/ fails with a permentant 403 forbidden loop

    apache 2.4.16
    PHP 5.5.30
    SQL 5.5.47-cll
    Linux x86_64
    Perl Version 5.10.1

    Moderator Marius L. J.

    (@clorith)

    @jmcgovern94 & @troydwhite

    Excellent! I had missed your post as you posted right before me@ jmcgovern94, but I can now consistently replicate the problems with mixed cases in the URL, great work!

    So for those affected, check Settings > General and make sure your address fields are all lowercase

    @marius

    that is not the only problem, on the one site that has the homepage loop, it has no lowercase settings but I can confirm that the site is in a sub directory

    ie instead of installed to the root

    http://www.testing.com

    it is in

    http://www.testing.com/wp-brokensite/

    it does also have a – in the sub directory name

    Moderator Marius L. J.

    (@clorith)

    @k0872
    Are you certain no part of the URL is uppercase? I’ not been able to reproduce anything using my test install with a sub directory name, even when using your format of wp-brokensite for it

    @marius

    Positive all lowercase.

    I have managed to get my server to whitelist the mod_security rules

    starting with

    #214620 & #214940

    which has fixed it for me.

    questions4wp

    (@questions4wordpress)

    @marius I also was able to solve my problem – I went to Settings -> General and changed both the WordPress Address (URL) and the Site Address (URL) to be all lower case (it was in camel case before), and the permalinks are back in working order. All of the pages are now running properly.

    My site is now exactly as it was – 4.4.1, permalinks involving %postname% (as opposed to the default, which is the post ID), same plugins installed, no new code in functions.php, no changes to mod_security. The only thing that was really changed was making the URLs lowercase in the settings.

    Thank you everyone for your help!

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    @marius I also was able to solve my problem – I went to Settings -> General and changed both the WordPress Address (URL) and the Site Address (URL) to be all lower case (it was in camel case before), and the permalinks are back in working order. All of the pages are now running properly.

    That’s good news, thanks for confirming that. 😉

    All – changing to lowercase and returning permalink to its post settings has fixed the problem, in line with what several others have reported.

    thanks to you folks for all of the hard work to find that solution

    Changing the site-adresse to lower case worked for me as well – awesome! 🙂

    Thank you for the help everyone!

    omg
    Settings->General set both ‘WordPress Address (URL)’
    & ‘Site Address (URL)’ to lowercase and it works now
    thnx

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    OK, I am closing this topic now. It’s getting out of hand because the problem is about how WordPress 4.4.1 handles Site URL and WordPress Address that are a mixed case.

    If you hit this bug then please do the following:

    1. Confirm that there are no mixed case in your WordPress Site URL or WordPress Address settings.
    2. If there are settings like that then please make them all lowercase.

      So http://MyServerName.com would become http://myservername.com. All lowercase. DNS doesn’t care if it’s upper or lower but 4.4.1 does for now.

    3. Clear your browser’s cache and cookies after that step.</l>
    4. Revisit your site and see if the infinite redirects still occur.

    If this fixes your problem then you’ve hit that bug.

    If this does not fix your problem something else is going on and then per the forum welcome please post your own topic. You can do so with this link.

    How-To and Troubleshooting

Viewing 15 replies - 46 through 60 (of 60 total)
  • The topic ‘ERR_TOO_MANY_REDIRECTS’ is closed to new replies.