Support » Fixing WordPress » ERR_TOO_MANY_REDIRECTS

  • Resolved JacobALund

    (@jacobalund)


    Hi
    I’m receiving this message on one of my websites when I try to enter it: ERR_TOO_MANY_REDIRECTS

    My site is http://www.bismv.dk

    The strange thing is that when I go to a sub-page such as http://www.bismv.dk/kontakt it works perfectly fine. Also, I can enter the control panel without problems.

    But I just can’t seem to be able to enter the site by it’s front-page. I’m not entirely sure when this issue started to happen, but it might have been in relation to the new version 4.4.1.

    Hope you can help!

Viewing 15 replies - 1 through 15 (of 60 total)
  • Sounds as though either a plugin is being called on the homepage or there’s an issue with a script on the file used to display the homepage.

    To rule out the plugins first deactivate them all and see if it comes online, if not try switching the theme to a default theme such as Twenty Sixteen and see if the homepage loads.

    Thank you for your answer!

    I just tried both your suggestions – but nothing helped.

    I’m using a static-homepage and I tried changing that to another too, but with no luck either.

    I have just taken a look at the .htaccess-file again to see if there’s anything wrong. And some for reason, iThemesSecurity has added the following to the file:

    [ Moderator note: code fixed. Please wrap code in the backtick character or use the code button. ]

    # BEGIN iThemes Security - Do not modify or remove this line
    # iThemes Security Config Details: 2
    	# Ban Hosts - Security > Settings > Banned Users
    	SetEnvIF REMOTE_ADDR "^5\.255\.253\.22$" DenyAccess
    	SetEnvIF X-FORWARDED-FOR "^5\.255\.253\.22$" DenyAccess
    	SetEnvIF X-CLUSTER-CLIENT-IP "^5\.255\.253\.22$" DenyAccess
    
    	SetEnvIF REMOTE_ADDR "^134\.249\.55\.134$" DenyAccess
    	SetEnvIF X-FORWARDED-FOR "^134\.249\.55\.134$" DenyAccess
    	SetEnvIF X-CLUSTER-CLIENT-IP "^134\.249\.55\.134$" DenyAccess
    
    	SetEnvIF REMOTE_ADDR "^104\.152\.189\.102$" DenyAccess
    	SetEnvIF X-FORWARDED-FOR "^104\.152\.189\.102$" DenyAccess
    	SetEnvIF X-CLUSTER-CLIENT-IP "^104\.152\.189\.102$" DenyAccess
    
    	SetEnvIF REMOTE_ADDR "^80\.86\.94\.7$" DenyAccess
    	SetEnvIF X-FORWARDED-FOR "^80\.86\.94\.7$" DenyAccess
    	SetEnvIF X-CLUSTER-CLIENT-IP "^80\.86\.94\.7$" DenyAccess
    
    	SetEnvIF REMOTE_ADDR "^185\.13\.202\.192$" DenyAccess
    	SetEnvIF X-FORWARDED-FOR "^185\.13\.202\.192$" DenyAccess
    	SetEnvIF X-CLUSTER-CLIENT-IP "^185\.13\.202\.192$" DenyAccess
    
    	SetEnvIF REMOTE_ADDR "^173\.255\.225\.130$" DenyAccess
    	SetEnvIF X-FORWARDED-FOR "^173\.255\.225\.130$" DenyAccess
    	SetEnvIF X-CLUSTER-CLIENT-IP "^173\.255\.225\.130$" DenyAccess
    
    	SetEnvIF REMOTE_ADDR "^157\.55\.39\.136$" DenyAccess
    	SetEnvIF X-FORWARDED-FOR "^157\.55\.39\.136$" DenyAccess
    	SetEnvIF X-CLUSTER-CLIENT-IP "^157\.55\.39\.136$" DenyAccess
    
    	SetEnvIF REMOTE_ADDR "^104\.250\.147\.218$" DenyAccess
    	SetEnvIF X-FORWARDED-FOR "^104\.250\.147\.218$" DenyAccess
    	SetEnvIF X-CLUSTER-CLIENT-IP "^104\.250\.147\.218$" DenyAccess
    
    	SetEnvIF REMOTE_ADDR "^142\.4\.218\.236$" DenyAccess
    	SetEnvIF X-FORWARDED-FOR "^142\.4\.218\.236$" DenyAccess
    	SetEnvIF X-CLUSTER-CLIENT-IP "^142\.4\.218\.236$" DenyAccess
    
    	SetEnvIF REMOTE_ADDR "^69\.73\.170\.122$" DenyAccess
    	SetEnvIF X-FORWARDED-FOR "^69\.73\.170\.122$" DenyAccess
    	SetEnvIF X-CLUSTER-CLIENT-IP "^69\.73\.170\.122$" DenyAccess
    
    	SetEnvIF REMOTE_ADDR "^68\.180\.229\.31$" DenyAccess
    	SetEnvIF X-FORWARDED-FOR "^68\.180\.229\.31$" DenyAccess
    	SetEnvIF X-CLUSTER-CLIENT-IP "^68\.180\.229\.31$" DenyAccess
    
    	SetEnvIF REMOTE_ADDR "^81\.171\.57\.163$" DenyAccess
    	SetEnvIF X-FORWARDED-FOR "^81\.171\.57\.163$" DenyAccess
    	SetEnvIF X-CLUSTER-CLIENT-IP "^81\.171\.57\.163$" DenyAccess
    
    	SetEnvIF REMOTE_ADDR "^91\.238\.228\.5$" DenyAccess
    	SetEnvIF X-FORWARDED-FOR "^91\.238\.228\.5$" DenyAccess
    	SetEnvIF X-CLUSTER-CLIENT-IP "^91\.238\.228\.5$" DenyAccess
    
    	SetEnvIF REMOTE_ADDR "^81\.171\.98\.66$" DenyAccess
    	SetEnvIF X-FORWARDED-FOR "^81\.171\.98\.66$" DenyAccess
    	SetEnvIF X-CLUSTER-CLIENT-IP "^81\.171\.98\.66$" DenyAccess
    
    	SetEnvIF REMOTE_ADDR "^130\.225\.26\.139$" DenyAccess
    	SetEnvIF X-FORWARDED-FOR "^130\.225\.26\.139$" DenyAccess
    	SetEnvIF X-CLUSTER-CLIENT-IP "^130\.225\.26\.139$" DenyAccess
    
    	SetEnvIF REMOTE_ADDR "^50\.23\.210\.133$" DenyAccess
    	SetEnvIF X-FORWARDED-FOR "^50\.23\.210\.133$" DenyAccess
    	SetEnvIF X-CLUSTER-CLIENT-IP "^50\.23\.210\.133$" DenyAccess
    
    	SetEnvIF REMOTE_ADDR "^185\.17\.30\.210$" DenyAccess
    	SetEnvIF X-FORWARDED-FOR "^185\.17\.30\.210$" DenyAccess
    	SetEnvIF X-CLUSTER-CLIENT-IP "^185\.17\.30\.210$" DenyAccess
    
    	SetEnvIF REMOTE_ADDR "^198\.20\.73\.170$" DenyAccess
    	SetEnvIF X-FORWARDED-FOR "^198\.20\.73\.170$" DenyAccess
    	SetEnvIF X-CLUSTER-CLIENT-IP "^198\.20\.73\.170$" DenyAccess
    
    	<IfModule mod_litespeed.c>
    		Order allow,deny
    		Allow from all
    		Deny from env=DenyAccess
    		Deny from 5.255.253.22
    		Deny from 134.249.55.134
    		Deny from 104.152.189.102
    		Deny from 80.86.94.7
    		Deny from 185.13.202.192
    		Deny from 173.255.225.130
    		Deny from 157.55.39.136
    		Deny from 104.250.147.218
    		Deny from 142.4.218.236
    		Deny from 69.73.170.122
    		Deny from 68.180.229.31
    		Deny from 81.171.57.163
    		Deny from 91.238.228.5
    		Deny from 81.171.98.66
    		Deny from 130.225.26.139
    		Deny from 50.23.210.133
    		Deny from 185.17.30.210
    		Deny from 198.20.73.170
    	</IfModule>

    I have no idea what it means or why it has been added.

    I have deleted the code and re-uploaded the file, but it still does not work.

    Moderator Marius L. J.

    (@clorith)

    Hi,

    The blocks added by iThemes here aren’t any worry, as they are just attempts at blocking bruteforces and such.

    You mentioned you are using a static front page, could you try switching it to showing your latest blog posts for a moment just to see if that’s what is causing issues for you?

    That works! I can now see the page: http://bismv.dk/

    But it doesn’t really solve the problem since I kinda still need to be able to show my homepage πŸ™‚

    Same exact issue with my roadtrekingcom site…. problem started with the upgrade
    Latest post displays… but I too need a static post

    Moderator Marius L. J.

    (@clorith)

    @pcmike

    Are you also using a static front page and it happens even if your plugins are disabled?
    Does changing it to show latest blog posts instead of a static front page also resolve it for you?

    @jacobalund

    Excellent, we’ve now narrowed down what might be happening, I’d like to try something, could you make a new page, call it something you’ve not called any other page before, and set that as your front page, does it still do the redirects then?

    @marius (Clorith)

    Done just that: http://bismv.dk/

    Same error πŸ™

    Same thing here, too.

    I just had the same problem on a client’s site.

    Does the homepage open when you change the permalink setting to the Plain?

    Also, do you have a redirection plugin installed?

    And are you using any caching plugin or service?

    @kostasni

    Changing the permalink doesn’t work.

    I have no redirection plugins installed, but I have W3 Total Cache. I have tried disabling all my plugins but that did not help either.

    changing to plain works, but of course, is not satisfactory because all my links are by post name…. This update has seriously broken by site and theme

    Moderator Marius L. J.

    (@clorith)

    It does seem like you have different problems at this point though, would you mind making a new thread for your issue @pcmike ?

    Moderator Marius L. J.

    (@clorith)

    @jacobalund

    Have you tried disabling all plugins, and then changing to a default theme (such as Twenty Fifteen) and seeing if the problem persists?

    Keep in mind that the nature of cache plugins is that they are often loaded even when disabled (due to files they need to place in your installation) so after changing your them and disabling other plugins, clear the cache for the plugin before disabling it.

    @marius (Clorith)

    I already tried this earlier on – remember? πŸ™‚ Had no effect.

    I just deleted the entire site (FTP) and uploaded a previous back up before the 4.1.1 version. Now it works fine. However, this obviously isn’t a long-term solution since the 4.1.1 was a security update.

Viewing 15 replies - 1 through 15 (of 60 total)
  • The topic ‘ERR_TOO_MANY_REDIRECTS’ is closed to new replies.