Support » Plugin: Favicon by RealFaviconGenerator » ERR_SSL_PROTOCOL_ERROR

  • Resolved steadyit

    (@steadyit)


    I was happy to find your RealFaviconGenerator plugin.

    I have used your website before on a previous (non WordPress) website to generate favicons.

    Here is the reason for opening up a support request.

    I am using the latest version of Google Chrome.

    I successfully installed this plugin in my WordPress installation.

    On the screenshot tap, I went to the first step:

    “Initial favicon setup screen. You are invited to setup your favicon.”

    When I selected a master picture from the media library, and clicked on the Generate button, Chrome displayed an error message

    The URL Chrome went to was https://realfavicongenerator.net/api/favicon_generator
    The error that Chrome displayed was ERR_SSL_PROTOCOL_ERROR

    I tried this same process in IE 11 and got a message that said this page cannot be displayed.

    I am running my site through CloudFlare’s Flexible SSL. I did have Development mode turned on and had cleared my cache.

    Do you have any advice what might be causing this error?

    I had backed up my WP installation before installing this plugin. So I rolled it back to the backup version. I would try installing it again if you had any recommendations on how I could get this working.

    https://wordpress.org/plugins/favicon-by-realfavicongenerator/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author phbernard

    (@phbernard)

    Hi,

    Thank you for reporting! I’m sorry you have troubles with the plugin…

    The surface error is easy to spot: RealFaviconGenerator doesn’t have SSL. So https://realfavicongenerator.net/api/favicon_generator fails, as expected.

    The root error is more puzzling: how can the plugin come up with an HTTPS URL? The fact that your site is behind CloudFlare Flexible SSL is clearly a hint, yet it doesn’t really explain how this can happen.

    Is there something you could check? When you are in your WP dashboard, in Appearance > Favicon, if you view the source of the page (ie. HTML) and look for realfavicongenerator.net/api/favicon_generator, what is the prefix? If should be http (as in: <form role="form" method="post" action="http://realfavicongenerator.net/api/favicon_generator" id="favicon_form">). If you see https, it means something has modified the RFG plugin on the fly. Maybe CloudFlare, maybe something else…

    ladislav.soukup

    (@ladislavsoukupgmailcom)

    it’s easy… there are few plugins to “enable” https and of course the cloudflare plugin itself… the main function of those plugins is to rewrite ALL links from http to https. This should only happen to internal links, but may happen to external links 🙁 Most of those plugins have exception list, so just add the realfavicongenerator.net… to exception list to notify the plugin not to rewrite it to https… (or hack this change using element inspector to the page).

    ladislav.soukup

    (@ladislavsoukupgmailcom)

    FYI: for CloudFlare plugin, there is help page: https://support.cloudflare.com/hc/en-us/articles/203652674 . There is an “HTTPS Protocol Rewriting” option that can cause this… From the plugin point of view – you can’t fight it (you can enable HTTPS – that is the only way).

    Plugin Author phbernard

    (@phbernard)

    Oh, I didn’t knew that! Thank you Ladislav for the information.

    Alright, I’m in the process of adding the SSL support to RealFaviconGenerator. That should be available in a few days.

    Wow! Thank you very much phbernard and ladislav. Great responses from both of you.

    As I mentioned that the start of this support ticket I was very impressed with your RealFaviconGenertor before jumping into WordPress. So I am very happy to see that it is a plugin.

    Maybe at this point I should hold off installing your plugin again until the new release with SSL support.

    If it helps I could keep all of my CloudFlare SSL settings as is, and test out the new version when it is ready.

    Thanks again to all for your involvement with this support request.

    Excellent!

    Plugin Author phbernard

    (@phbernard)

    Thank you for your feedback!

    SSL support enabled! Could you give it another try?

    I did not make and changes to my CloudFlare SSL settings.

    I reinstalled the plugin.

    And everything worked perfectly.

    Thanks for adding SSL support, much appreciated!

    Plugin Author phbernard

    (@phbernard)

    Excellent! Thanks for reporting.

    One ticket closed today!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘ERR_SSL_PROTOCOL_ERROR’ is closed to new replies.