Support » Plugin: Simple Cache » ERR_CONTENT_DECODING_FAILED on 404 pages with ‘Enable Compression’

  • Resolved mprewitt

    (@mprewitt)


    If I tick the enable option for ‘Enable Compression’ in Simple Cache, I get a strange error.

    The conditions for this error are:

    – ‘Enable Compression’ in Simple Cache is active
    – The browser is Google Chrome or Firebox (and maybe IE) — does NOT affect Safari
    – The page is the WordPress 404 error page — does not affect any other pages that I’ve seen

    Another thread somewhere suggested that a PHP file that ends with a space character after the closing “?>” can cause this, but I did a text search and none of the files end that way.

    Not sure what else to try.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Taylor Lovett

    (@tlovett1)

    Can you link to where this is happening?

    winston_wolf

    (@winston_wolf)

    Hi,
    I’ve got the same problem. It works only, when the .php extension is added, otherwise that error occurs.
    You can check it: http://popardowski.pl/404
    ..and working sample: http://popardowski.pl/not-found.php

    Thread Starter mprewitt

    (@mprewitt)

    Here it is on my site:

    https://www2.lcdhd.org/404
    (or you can do something like https://www2.lcdhd.org/xyz to trigger a 404, same result)

    Just as winston_wolf says above, if I type:
    https://www2.lcdhd.org/not-found.php
    …it works.

    Thread Starter mprewitt

    (@mprewitt)

    The previously mentioned site has gone live, with compression disabled. But the issue can still be seen at another site, https://dev.lcdhd.org/404, etc.

    Plugin Author Taylor Lovett

    (@tlovett1)

    Fixed in 1.5.6

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘ERR_CONTENT_DECODING_FAILED on 404 pages with ‘Enable Compression’’ is closed to new replies.