Support » Plugin: WP Product Review Lite » Erorr: JSON-LD: Missing ‘,’ or ‘}’ in object declaration

  • Resolved Yorge

    (@jerrry)


    Hello, I have been a paying customer for 3 years for Product reviews plugin, but now you ended the Premium version, so I have to switch back to Lite version πŸ™

    But now I am getting errors caused by your plugin (100% sure, because when I turn it off, all is okay). The issue is in Structured Data Testing Tool by Google, where I am getting this error:

    lJSON-LD Missing ‘,’ or ‘}’ in object declaration.
    in class Uncategorised Errors.

    Can you please release update which will fix this issue? I have stored hundreds of reviews by your plugin, so I need to be working again πŸ™

    Temporary solution is to turn off “Enable Rich Snippets” in plugin settings, I need need these data for Google search results.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Contributor contactashish13

    (@rozroz)

    @jerrry can you please share the following?

    • a URL to the page that contains this problematic review
    • a snapshot of the error
    Thread Starter Yorge

    (@jerrry)

    Hello, thanks for fast reply. Problem is in every review, where we use WP Product review box, for example here https://dooomer.shortcm.li/25OvpK

    And here is the results from Structured Data Testing Tool https://dooomer.shortcm.li/C9d3f8

    Plugin Contributor contactashish13

    (@rozroz)

    @jerrry looks like the problem is with the description element. We use the post excerpt to populate this and it is supposed to contain only text. In your case it contains markup also, which is causing this problem. Please check if your post excerpt is being added by some other plugin and, if so, make sure it populates only text content there without markup.

    Thread Starter Yorge

    (@jerrry)

    Thanks for reply. I am not using any plugin which can affect this. Maybe only Yoast SEO Premium, but this is one of the most common plugins for WordPress. Can you please be more specific with this issue? I have no clue how to fix this.

    edit: btw, can I get an e-mail address to someone from your team? I maybe found something in your plugin, which can cause this, but I want to describe it via e-mail, not here, because it will contain some personal data.

    • This reply was modified 1 year, 6 months ago by Yorge.
    Plugin Contributor contactashish13

    (@rozroz)

    @jerrry this link may help you understand the concept of excerpts. Your excerpts contain HTML markup when they should only contain text so it may be some configuration of your website.

    PS – you can contact us at friends at themeisle dot com. Please note that issues pertaining to the free plugin will be addressed only on this forum.

    Thread Starter Yorge

    (@jerrry)

    I will try to inspect more the excerpt element on my site. I was tried to turn off some plugins, which can affect this, but with no results for now. I will try to do more test.

    Do you think than issue with excerpts should be also influenced by template?

    Plugin Contributor contactashish13

    (@rozroz)

    @jerrry any component could be interfering. You may want to disable all plugins and test with the default WP theme.

    Plugin Contributor contactashish13

    (@rozroz)

    We haven’t heard from you in sometime so marking this as Resolved. If you continue to face an issue, please create a new ticket. We’d be happy to help.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Erorr: JSON-LD: Missing ‘,’ or ‘}’ in object declaration’ is closed to new replies.