Support » Plugin: Longer Permalinks » eror 500 (Request Timeout) with Longer Permalinks

  • Resolved amireza2000

    (@amireza2000)


    hello

    i have 300/000 products and i see my wordpress panel become very slowly and someetimes i cant login in wordpress panel and alot of time get eror 500 (Request Timeout) after that i disable Longer Permalinks my wordpress panel become fast and normal

    1-what i should do ?

    2- what recource i should say to hosting admin to increase to solve problem ?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author antithesisgr

    (@antithesisgr)

    Hi,
    this ain’t normal because plugin is not utilizing resources this way.

    Which plugin version do you have installed?
    How long ago have you done the plugin installation?

    Thread Starter amireza2000

    (@amireza2000)

    hi dear

    last version i use

    one year
    but now i change my webhosting and in new hosting every time i enable your plugin i can’t open every page of wordpress panel , my site is ok but every panel page get (Request Timeout eror)

    Thread Starter amireza2000

    (@amireza2000)

    also in last hosting i think when your plugin enable my panel It was a little slow loading

    plz attention to this : i have a lot of products (300/000) maybe this affect to this.

    Plugin Author antithesisgr

    (@antithesisgr)

    Do you have any relevant lines in your error_log when you get the 500 error?
    All 50x errors should have relevant entries in your error log.
    Please send the relevant error you are getting.

    Also you wrote that you have it 1 year already, you mean you had this enabled for about 1 year? And now only on your new hosting you see this problem?

    Thread Starter amireza2000

    (@amireza2000)

    1-
    when i enable plugin my panel down and only show eror 500 and nothing else
    but when go to disable plugin with this adrees :
    https://www.mysite.com/wp-admin/plugins.php?action=deactivate&plugin=longer-permalinks%2Flonger-permalinks.php&plugin_status=all&paged=1&s&_wpnonce=c7485d4d52

    i get to eror from debug :

    Fatal error: Out of memory (allocated 2097152) (tried to allocate 167936 bytes) in /home/h169650/domains/mysite.com/public_html/wp-includes/wp-db.php on line 2022

    Fatal error: Out of memory (allocated 2097152) (tried to allocate 172032 bytes) in /home/h169650/domains/mysite.com/public_html/wp-includes/wp-db.php on line 2022

    whats your analysis ? my memory is low ? my host memory is 1Gig

    2-
    yes in the last hosting i dont have eror 500 but sometimes my wordpress become low loading but im not sure this is for your plugin.

    Plugin Author antithesisgr

    (@antithesisgr)

    Ask your hosting provider (or find this yourself in your hosting panel if you have one) to increase your PHP “memory_limit”.

    This limit is the reason you get this error.
    It is not the same as your total memory limit in your hosting account.
    Increase your PHP memory limit and retry until you don’t get this error. The reason you are getting this error is low “memory_limit” in your PHP.

    Also ask your hosting (or find this yourself if available in your hosting panel) to increase the time (in seconds/minutes) that your PHP is allowed to execute. Also the time your http response can take to send a response. For example “max_execution_time” for PHP etc, your hosting will guide you here.

    If this is the first time you enable the plugin, since your website has a large database (with a lot of records in wp_posts table because of 300000+ products), then it will take some extra seconds the first time you load your website (depending on your hosting). This is true only for the first load.

    Thank you.

    Thread Starter amireza2000

    (@amireza2000)

    i resarch and i get some result

    PHP “memory_limit”. in my last hosting is 256mb !
    PHP “memory_limit”. in my new hosting is 1gig !

    but in my new hosting your plugin get eror PHP “memory_limit” !

    i ask from hosting to increase PHP “memory_limit”. but they say 1gig is maximum of this and can’t increase that.

    can i send user and pas and wp panel link for you to check my panel ?
    i become confuse.

    Plugin Author antithesisgr

    (@antithesisgr)

    Hi,
    in the error messages you have sent, you can see:

    “allocated 2097152”

    This is bytes.
    This is exactly 2 MB!

    It wasn’t allowed to go above 2 MB.
    😉

    Thread Starter amireza2000

    (@amireza2000)

    WE INCREASE RESOURCE AND PUT SEVERAL CODE IN WPCONFIG AND HTACCESS BUT YET WE HAVE PROBLEM

    WP CONFIG :
    set_time_limit(300);
    define( ‘WP_MEMORY_LIMIT’, ‘256M’ );

    .htaccess :
    php_value max_execution_time 300

    Plugin Author antithesisgr

    (@antithesisgr)

    Hello,
    how much is your PHP memory_limit now?
    Please note that WP_MEMORY_LIMIT is not the same as the PHP memory_limit.

    Please go to “Tools” → “Site Health” → “Info” and see the line PHP memory limit there.

    A way to check this for your hosting regardless of your WP installation, is to create an empty new php file and put inside only one php command: phpinfo();
    and visit this file using your browser to see all active PHP settings (and memory limit).
    Remember to delete this new file afterwards for security reasons.

    Thank you.

    • This reply was modified 1 year, 2 months ago by antithesisgr.
    • This reply was modified 1 year, 2 months ago by antithesisgr.
    • This reply was modified 1 year, 2 months ago by antithesisgr.
    • This reply was modified 1 year, 2 months ago by antithesisgr.
    Thread Starter amireza2000

    (@amireza2000)

    4000

    plz check this

    http://www.yun.ir/3123123213

    our resourceis enough but i don’t know why we have this problem

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘eror 500 (Request Timeout) with Longer Permalinks’ is closed to new replies.