Support » Plugin: Easy Peasy MailChimp Ajax Form » EPM works in pages but not widgets

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Alessandro Tesoro

    (@alessandrotesoro)

    Hello,

    Can you explain what exactly is the issue? I’ve just tested your widget and validation seems to be working fine. Does anything happen after submitting an email?

    When I use the Follow Us widget on that page, I always get a “Please add a correct email address.” error, even if I’ve entered a correct email address.

    Hi. The EPM form in a widget is still not working. The form gives the response “Please add a correct email address.” even if you enter a correct email address.

    I have enabled debug on the site, so if you go to http://bic-history.org/epm-test and use the form at the top of the right sidebar, you will see the following errors after submission:

    Notice: Undefined index: epm_list_id in /home/bichsadmin/public_html/content/plugins/easy-peasy-mailchimp-ajax-form/includes/ajax.php on line 13

    Notice: Undefined index: epm_email in /home/bichsadmin/public_html/content/plugins/easy-peasy-mailchimp-ajax-form/includes/ajax.php on line 18

    Notice: Undefined index: display_name_fields in /home/bichsadmin/public_html/content/plugins/easy-peasy-mailchimp-ajax-form/includes/ajax.php on line 31
    Please add a correct email address.

    Thank you for any help you can provide.

    Plugin Author Alessandro Tesoro

    (@alessandrotesoro)

    Hello,

    sorry for the delay, i’m currently traveling and don’t have an active internet connection. As of now there cannot be multiple subscription forms on the same page like the one you linked. Because the verification takes place via ajax based on the ID of the form. This is probably a limitation i will remove at some point into a future update.

    Regards.

    Finally found the fix for this. The shortcode was being used in a text widget with auto-insert <p> tags enabled. I disabled that and it worked fine.

    However, with DEBUG enabled I still get the same errors after signing up. But it doesn’t keep the plugin from working.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘EPM works in pages but not widgets’ is closed to new replies.