Support » Plugin: EP Admin Messages » ".ep-config.json" does not contain valid JSON.

  • Resolved freakzone89

    (@freakzone89)


    Hey guys,

    your plugin provides exactly the feature i was looking for, but how do i set it up?

    What i’ve done is, to create a .ep-config.json file to the folder of my child-theme. I inserted the lines of code from your ep-config-example.json and now the message on my dashboard is:

    EP Admin Messages: Config file “.ep-config.json” does not contain valid JSON.

    Do i have to add something like <?php at the beginning and ?> at the end? Hope you can help me.

    Cheers

    http://wordpress.org/plugins/ep-admin-messages/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Pär Thernström

    (@eskapism)

    hm, if the contents in your json is exactly the same as the example file then it should work. could we try a more minimal examle. what if you paste the contents of this file:

    https://gist.github.com/anonymous/6605760

    as i added this code, it works!

    i tried another piece of code and added

    {
      "messages": [
        {
          "message": "Test.",
          "user_role": "admin",
          "location": "dashboard"
        },
      ]
    }

    and now it’s also:

    EP Admin Messages: Config file “.ep-config.json” does not contain valid JSON.

    got it!

    it seems to be the arrangement. i inserted it this way:

    {
    "messages": [
    {
    "message": "This message is visible on all screens, for all users.",
    "location": "post_type:event, post_type:post"
    }
    ]
    }

    and all works fine

    Another issue is, that the plugin can’t deal with “ä,ö,ü” letters. So i replaced them in the texts and it works.

    Plugin Author Pär Thernström

    (@eskapism)

    hm, have you saved the json-file in utf-8? i’m pretty sure it works with åäö etc (i’m swedish myself and we have lots and lots of those funky characters!)

    i don’t know if it’s in utf-8, but i only edited it in notepad and i’d say there isn’t a change in the file-format.

    Plugin Author Pär Thernström

    (@eskapism)

    Ok. Thanks for the info, I’ll double-check it on my end.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘".ep-config.json" does not contain valid JSON.’ is closed to new replies.