Support » Plugin: Image Gallery Plugin for WordPress - Envira Photo Gallery » Envira plugin lost all images during site migration

  • Resolved funt565

    (@funt565)


    I transferred the site to WordPress from Envira to another domain manually.

    Media files from the uploads folder are also copied. Individual images and videos work great on the new site.

    I did a dump import from the old database, then using Notepad ++ I changed the key setting in the domain name.

    Everything works fine except for Envira. This is a big problem for me, I have 150 galleries and more than 1GB of media files.

    How can this problem be solved?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hello @funt565

    You should have used find and replace because the gallery data is stored serialized and what you did broke the database.

    If you need further assistance please send a support request and we will check for you.

    Thank you!

    That’s exactly what I did. Used the function of mass replacement. Example: site1.com -> overwrite in a database dump on site2.com

    What is my mistake and what is the best way to transfer a site with a plugin to a new domain?

    UP
    I still have backups, this is not a problem, just tell me the correct way

    • This reply was modified 10 months, 1 week ago by funt565.

    The problem was solved as follows: a dump of the database was uploaded to the new site, then UPDATE wp_options SET option_value = REPLACE(option_value, 'https://oldsite.com', 'https://newsite.com') WHERE option_name = 'home' OR option_name = 'siteurl';query was executed through Phpmyadmin. The “Better Search Replace” plugin was installed. With its help, it was possible to correctly rewrite the new URLs, including in the table used by Envira.

    Good luck!

    great to hear @funt565 thank you very much for the update!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Envira plugin lost all images during site migration’ is closed to new replies.