Support » Fixing WordPress » Entry Saving Loads Indefinitely

  • Hi folks. I’ve run into another problem with WP. Lately, when I go to edit an existing post and hit Save, it winds up loading indefinitely. I know whatever I’ve changed is saved because it appears on the site.

    I’ve tried clearing out my history, cookies and cache, as well as restarting it to see if this does the trick. My final guess is that its a server related issue [i am using dreamhost] but I could use some advice here.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Could be the pings sent out when posting or saving an edit to a post. Try (at least temporarily) removing any of the service urls listed under Options > Writing, “Update Services” and see if that helps.

    Moderator James Huff


    It’s not a server-related issue. It’s due to the fact that WordPress sends a trackback to every URL in your post and waits for a response from each before returning to your post page. Your blog post is posted immediately, but you’ll have to wait because some external website take forever to return pings. I’m on DreamHost as well, and I’ve never had to wait past two minutes.

    great. thank you everyone!

    I’ve had this problem and it continues on and on for ages. It is based upon several things.

    1) comments, pings, and trackbacks. The more links in the post, the longer it takes to load.

    2) code processing – the more html, graphics, links and things you have in there, the longer the time it tends to take to get into the database.

    3) post size – a 14 word post zooms in there, but a 300000 word post takes a “little longer”.

    4) Server speed – sometimes the server just slows down, like during maintenance, backups, or just busy times at the old server water cooler. No clue, just sometimes it is consistently slowing down at the same times every day – which implies server stuff.

    5) Internet times of the day aka Internet Rush Hour – I find that during the day, my loading times are pretty fast, but in the evenings, especially popular sit at home and stare at the computer evenings, things load slowly.

    6) Access Speed – obviously, the faster the Internet connection, the faster the load – but sometimes that tends to slow down for whatever mysterious reasons that haunt your modem or IP.

    And the biggest criminal of ALL?????

    7) WordPress’s Edit Preview. Yes, the information may get into the database rocket fast, but the loading of the screen still has to load all that preview stuff down in the Edit Preview below the posting area. I think personally that this is a useful feature, but I can’t tell you the last time I ever looked down there. The styles are not present – so all you see are the words and the pictures all looking pitifully gross in their unlaid out layout. I want to preview what it will REALLY look like, but this feature doesn’t do that…yet. There is a WYSIWYG plugin, somewhere, that will actually show you the actual site from including the styles right in the edit window, but it slows everything down if you are doing massive stuff. So if you have a lot of graphics or ads in the post, you have to wait through them all loading up on the screen if you hit SAVE AND CONTINUE EDITING.

    I’ve been able to speed things up during the massive edits and postings as I’ve been moving my static site into WordPress by turning off all pingbacks and comments, and I wish there was a way to turn on and off the Edit Preview area of the Edit screen, but the slow loading is hit and miss. Frustrating.

    I’ve found that if you are tired of waiting, you can click the Manage screen if you are done with the post, and the post will still have already loaded up into the database – most important! You can go on. But if you hit the SAVE twice while you are waiting for it to load, it can and does double post your post, so you will have to delete one. Oh, yeah!

    Sorry to bring back an old thread, but this problem happens to me as well, but the strange thing is, when I make a new post, WordPress actually somehow quotes a previous post and sticks it into the comment of that post.

    Now while I delete these dodgy comments as soon as I see them, it’s very annoying and makes life difficult…any ideas?

    Re: WordPress’s Edit Preview
    You can get around this by saving your post as “private”, and then viewing it on your site, and clicking “Edit” if you don’t like how it turned out.

    I want to preview what it will REALLY look like, but this feature doesn’t do that.

    Yes it does…doesn’t it? In the preview pane at the bottom, just click the title of your entry – you’ll be whisked off to your website where you can see the page looking as it does in your design.

    And as far as I know, the page it shows is only viewable if you are the admin.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Entry Saving Loads Indefinitely’ is closed to new replies.