Entry-metas: inconsistency (even maybe a bug?) (4 posts)

  1. ElectricFeet
    Posted 2 years ago #

    As part of the ongoing series: "How did I manage to do this and not notice it?":

    I have entry metas showing on my post list. I know how to remove them easily enough, but the question is "how did they get there?".

    If I run plain Customizr (no child, no plugins, nothing), they are showing — both on the post list and the post. Yet on demo.themesandco.com/Customizr they don't.

    I note that I am using a separate page for my blog posts. So, testing further, I find that:
    - If you have your posts listed on the home page then the metas don't show
    - If you have your posts listed on a separate blog page, they do show.

    (In both cases, the default is to show the metas on the individual/single post's page.)

    I would expect the behaviour to be the same in both cases, yet it is not.

    Is this inconsistency a bug or a feature?

  2. nikeo
    Theme Author

    Posted 2 years ago #

    Hi @Electricfeet, this has been made on purpose because I thought the home had a cleaner look whithout those metas.
    It is very easy to display them on home though with a dedicated filter (you know I love filters ! ) : tc_show_post_metas

    add_filter ( 'tc_show_post_metas' , 'display_metas_on_home' );
    function display_metas_on_home( $bool ) {
    //returns original boolean if not home
    if ( ! tc__f('__is_home') )
    return $bool;
    //displays if home
    return true;
  3. nikeo
    Theme Author

    Posted 2 years ago #

    Thanks for asking btw, it made me realize that I should make it more clear, or add a simple checkbox setting in customizer about this.

  4. ElectricFeet
    Posted 2 years ago #

    Thanks Nicolas. I agree it's cleaner without them on a post list — whether it's on the front page or a blog page — and I intend to switch them off. A checkbox would be great.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic