Support » Plugin: Glossary » Entry full content on archive page

  • Resolved Enis

    (@enistrevisi)


    How can I set the plugin to get the glossary entry full definition also in the archive page?

Viewing 12 replies - 1 through 12 (of 12 total)
  • So you are talking about use the content of the term and not the excerpt.
    Actually this is the behaviour of the plugin that use the content in the archive but in some cases can depend on the theme this wrong behaviour and we cannot do so much.

    Enis

    (@enistrevisi)

    You are right. It’s my theme doing strange things.

    Thanks!

    Enis

    (@enistrevisi)

    @mte90, I’ve looked into this matter and apparently it’s glossary that makes my theme behave in an awkward way.

    Keep in mind that I’m using a Genesis child theme: something robust and well coded.

    Blog page and all the archives do not show the full content unless I set a very high character limit in the Genesis->Theme Settings page. They either show:

    • the excerpt with the “[read more]” NOT linked to the article—that happens if I set “Display”->excerpt—or they show part
    • all the content with a “[Read more]” link if I set “Display”->entry content and “Limit content to”->some high number text.

    If I set “Limit content to” to zero, I get neither any content at all nor a “[read more]” link, whereas, if set to zero, this option should set Genesis to display the full entry content in blog and archive pages.

    I tried deactivating all the plugins and switching to Genesis default theme and the problem persisted.

    • This reply was modified 6 months, 1 week ago by  Enis.
    Enis

    (@enistrevisi)

    I edited /public/includes/Glossary_Genesis.php from line 41 to line 60 this way:

    
                if ( is_singular() || genesis_get_option( 'content_archive' ) ==="full") {
                    $content = get_the_content( get_the_ID() );
                    if ( is_single() && 'open' === get_option( 'default_ping_status' ) && post_type_supports( get_post_type(), 'trackbacks' ) ) {
                        echo '<!--';
                        trackback_rdf();
                        echo '-->' . "\n";
                    }
                    if ( is_page() && apply_filters( 'genesis_edit_post_link', true ) ) {
                        edit_post_link( __( '(Edit)', 'genesis' ), '', '' );
                    }
                } else if ( 'excerpts' === genesis_get_option( 'content_archive' ) ) {
                    $content = get_the_excerpt( get_the_ID() );
                }
    /*
                if ( is_archive() ) {
                    if ( genesis_get_option( 'content_archive_limit' ) ) {
                        $content = get_the_content_limit( ( int ) genesis_get_option( 'content_archive_limit' ), genesis_a11y_more_link( __( '[Read more...]', 'genesis' ) ) );
                    } else {
                        $content .= genesis_a11y_more_link( __( '[Read more...]', 'genesis' ) );
                    }
                }
    */
    

    in particular, line 41 becomes:

    
     if ( is_singular() || genesis_get_option( 'content_archive' ) ==="full") {
    

    and the lines from 54 to 60 are commented, since Genesis takes already care to add the “[read more]” link.

    This solves the problem.

    However, some shortcodes and twitter cards are not rendered.

    Plugin Author Daniele Scasciafratte

    (@mte90)

    So it seems a problem of compatibility with genesis.
    I will look on it 🙂

    Plugin Author Daniele Scasciafratte

    (@mte90)

    I tried on genesis and I don’t have the problems that you are saying.
    What is the theme that are you using?

    Enis

    (@enistrevisi)

    The theme I’m using is called “themecore”.

    You can find it here: https://github.com/bradpotter/themecore

    Meanwhile I’ll try disabling all the other plugins.

    Plugin Author Daniele Scasciafratte

    (@mte90)

    In the meantime I released the 1.4.0 that do few fixes for genesis 🙂

    Enis

    (@enistrevisi)

    I’ve disabled all the plugins, the theme and left just genesis, bare.

    The problem persists.

    Plugin Author Daniele Scasciafratte

    (@mte90)

    I rewritten all the code that support Genesis to fix all this stranges behaviour.
    The new release 1.4.1 (already published) will fix everything (the majority of problems happen on archive and not on single pages).
    Try it 🙂

    Enis

    (@enistrevisi)

    It worked 😀

    Thanks a lot! ^_^

    Plugin Author Daniele Scasciafratte

    (@mte90)

    You are welcome and forget to review our plugin!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Entry full content on archive page’ is closed to new replies.