Entries not showing, navigation becoming bulky (5 posts)

  1. bjaslagter
    Posted 3 years ago #

    Hi there,

    First of all: love your Guestbook plugin, the users of my site do as well. However, over time, some problems started to occur.

    1. Entries not showing in Dashboard
    When I click on "Entries" in the WordPress Dashboard, nothing shows up. How can I resolve this? I added a picture of how it looks...
    Screenshot of Entries in Dashboard

    2. Page numbers / navigation is becoming bulky
    Since we use the Guestbook quite a lot on our page, we have over 2500 entries. This results in an enormous amount of pages, and the page numbers are taking up significant space on the page. I made them black to try and hide it, but they still use the space... Is there an option to show them as < 1 2 3 ..... last > for example? Agagim, I added a screenshot. Hope you can see the numbers (black on blackish)...

    PS: more posts per page doesn't work for us, some info is shown below the entries on a mobile device. This results in too much scrolling...

    Paganumbers becoming bulky

    Site adress:


  2. DanielSchurter
    Plugin Author

    Posted 3 years ago #


    1.) It could be a problem with your 2500 entries but it was tested with up 30k entries without any problems.
    Check the size of $num_rows0 on admin.php, line 2344 and $query1 in line 2393. Maybe you have to limit $_REQUEST['from'] in line 2291 to a fix value manually.

    2.) On dmsguestbook.php, line 434


  3. bjaslagter
    Posted 3 years ago #

    Hi Dani, thanks for your reply! I don't know anything about PHP, but here are my findings:

    1. Entries not showing
    2344: for($q=0; $q<$num_rows0; ($q=$q+$gb_step))

    2393: foreach ($query1 as $result) {

    2291: " . sprintf("%d", $_REQUEST['from']) . "," . sprintf("%d", $gb_step) . ";");

    Could you provide me with some suggestions? What should I alter? Again, PHP is msystery to me... ;-)

    2. Page numbers

    Foundd it: for($x=0; $x<$num_rows1; ($x=$x+$var_step))

    Again, no idea how to alter it...

    Looking forward to your help!


  4. DanielSchurter
    Plugin Author

    Posted 3 years ago #

    Hi Berend

    To find out whether the sum of entries is a problem, replace $num_rows0, $num_rows1 and $_REQUEST['from'] with a numeric value, like 150.

    Otherwise install a local webserver on your computer with WordPress and DMSGuestbook. An easy configurable webserver can be found here. It's possible that your ISP has some database query restriction...


  5. bjaslagter
    Posted 3 years ago #

    Hi Daniel,

    Thanks again. When I deleted a couple op plugins (BuddyPress for example), everything worked again. It seems a lack of memory is the problem. Good to know for future problems.

    The pagenumbers are still kind of a problem, didn't try the option you mentioned yet.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • DMSGuestbook
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic