Support » Plugin: Entry Expiration for Gravity Forms » Entries not being deleted, log says “not due to be run yet”

  • Resolved alisonleemckay

    (@alisonleemckay)


    Hello! I have this plugin set to delete entries older than 4 months, and to run every 1 hour (for testing purposes), and my entries older than 4 months are not being deleted. Per your other support responses, I turned on logging. I’m getting the same log result for each form:

    DEBUG --> GF_Entry_Expiration::maybe_run_deletion(): Skipping deletion for form #3 because it is not due to be run yet.

    I only have the plugin set up locally at this point, so no logging URL to share with you, but all of the log results look like the line above. Can you shed any light on what’s wrong? How can it not be due to run yet if my entries are older than the time set and more than 1 hour has passed?

    Thank you!
    –Alison

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Travis Lopes

    (@travislopes)

    Hi Alison,

    Do you happen to have any plugins installed that would prevent setting or deleting transients?

    No, but I decided to set up the plugin on a live server to rule out anything with my local environment. Now I’m getting different log results but still having trouble – I entered the same expiration settings (delete entries older than 4 months, every 1 hour), and according to the log the plugin ran correctly, but none of my entries older than 4 months were actually deleted. The page numbers in the log also do not match the number of pages displayed in the Gravity Forms entries interface/pagination. Not sure if these are supposed to match, but according to the log form #1 has 27 pages, and in my GF interface it has 47 pages of entries.

    Here’s the log:
    https://www.girliepress.com/forms/wp-content/uploads/gravity_forms/logs/gravity-forms-entry-expiration_ff01efb64ebd7bc7d9c82f0335a840650cd493bd.txt

    Thanks again for any help!

    Actually Travis, this is resolved! I see now that the entry expiration plugin needs to run a few times to go through all the entries (one of my forms had 900+). They’re starting to delete properly now, and I expect that they’ll all be wiped once the plugin runs 2-3 more times. Still not sure why it never worked locally, but that’s not a problem since it is working on the live site. Thanks for your help!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.