WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
Entire site goes HTTPS after visiting one HTTPS page... (6 posts)

  1. daynew
    Member
    Posted 1 year ago #

    I have used the plugin to set my site to HTTPS for certain pages. The problem is once you visit one of those pages and then go to a different page that is not set to HTTPS it stays on HTTPS. Is there a setting or something I am doing wrong?

    http://wordpress.org/plugins/wordpress-https/

  2. junipercoyote
    Member
    Posted 1 year ago #

    I'm having the same issue--would love a solution.

  3. ReactorShop
    Member
    Posted 1 year ago #

    This solution worked for my WordPress multisite installation:

    a) Edit each post or page you need HTTPS for and select "Secure post" in the HTTPS widget located below the "Update" button. Then click "Update".

    (Don't do this! -> After doing this, In a new browser I got into my website, and even though I started with HTTP at my home URL, the moment I selected an HTTPS forced page, all the following pages I clicked were forced into HTTPS, even though they weren't supposed to be)

    b) Go into the specific site child blog dashboard (do not do this in the Network admin HTTPS sidebar menu)

    c) Click the HTTPS side bar menu (or click on it inside the sidebar "Settings" menu)

    d) Click "Force SSL Exclusively".

    e) Click the "Save Changes" button.

    I hope this helps those with multisite installations.

  4. Preeminent
    Member
    Posted 1 year ago #

    I'm having this same issue. Have you figured this out? I only need my checkout page secure. As soon as you try and go to another page, it tries to load the page as HTTPS/secure again. And the site looks broke, with no CSS styles.

    Any ideas on how to fix this, guys?

  5. esmi
    Forum Moderator
    Posted 1 year ago #

    @Preeminent: If you require assistance then, as per the Forum Welcome, please post your own topic.

  6. Clifford Paulick
    Member
    Posted 1 year ago #

    Yes, this is exactly what the "Force SSL Exclusively" checkbox is for. It means "unless I specify it to be HTTPS, force it to HTTP".

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags