Support » Installing WordPress » Entire Blog Not Showing at All – Public_html dissapeared!

  • Resolved betterforbusiness1


    I am trying to upgrade my blog to the new version of wordpress. I followed the detailed upgrade instructions as given on the wordpress website.. I backed up everything it said to backup.

    However, when I got to step 6, and it was time to put the wordpress file under a parallel directory (i named it “uploads”).. I think it just messed everything up, because I had forgotten that I had already used that same directory name when I initially uploaded the first version of wordpress.

    I used dreamweaver’s ftp client to upload the upload file containing the wordpress file and all of it’s contents to the respective category. I accidently placed the new uploads file in “wp-includes” folder. I tried to delete it, and I then wasn’t able to connect through ftp any longer. I logged in to my cpanel file manager and immediately noticed that Public_html was GONE! The entire blog is down now, and I tried messing with the files and re-creating a public_html and putting the relevent contents into it, but I believe it just made matters worse. I am so very confused now! And my blog (that gets a very good amount of traffic to it) is completely shut down and useless!! I would definitely appreciate any help given… I am near tears! ahhhh!
    thank you in advance

Viewing 9 replies - 1 through 9 (of 9 total)
  • Well if you have a backup of your wordpress files and database then you have a fall backup position.

    When I click on your link I see that it show an uploads and a wp-admin folder. I would think that means you do have a public_html folder.

    Was WordPress originally installed in public_html or was it installed in public_html/some_subfolder (like wordpress or blog)?

    It might be useful to restore your original wordpress files, make sure your blog works, then start the upgrade process over.

    No, somehow the public_html was deleted during the process, and the entire site would’t show (just an error). I then re-created the public_html file myself. (i design websites so I know that this folder is needed for all front-end aspects)

    Originally, I accidently put the new worpress file which was contained in an “uploads” file as well, in the wp-includes file… I believe that’s in public_html, but am not sure, as I was doing it using dreamweaver ftp. I am pretty sure it WAS in the public_html.

    My main problem is that I don’t quite remember all of the files that were inside of the public html file, and how they were arranged. Because when it accidently deleted public_html, the “uploads” and “wp-admin” file in the main directory still remained… along with a few other files by themselves. What I originally backed up seemed to be all of the same files that are located in “uploads” file ..? That is what is confusing me, because usually dreamweaver automatically shows only what is in the public_html by default.

    Were all of the Wp files originally contained in “uploads” and “wp-admin”… outside of the public_html anyhow? Or were they inside, and somehow got knocked outside of public_html? I am not so knowledgable about most backend stuff, but I am hoping I can fix this… as that blog is super important . thank you for your time!

    The standard WordPres installation has 3 folders, wp-admin, wp-content, and wp-includes. Along with those 3 folders there are 21 files. Of course, that 21 files doesn’t count the wp-config.php that you create. None of these files would reside outside of public_html.

    Might want to download a current distribution and look at how the folder/files are setup.

    If you did follow the Upgrading WordPress instructions don’t forget that you have a backup that you could look at (and rely on).

    Another note–public_html has permissions 750 on my host.

    I’m noticing from the newer version available, that my old version is missing index.php and a few other files, because there are only 13 other files, rather than the 21 you just mentioned. wow… I am puzzled.

    Before going further, please verify that you do have a backup of your database.

    Yes, I do.

    Except for the few files that I mentioned were missing. I backed-up everything, but that file is mysterious to me.. I don’t ever remember seeing it. I do have all of my content though. I backed it up into the mysql file it specified, and double checked it to make sure everything was there when I did it.

    If you are not having luck restoring, then you might want to get a professional involved:

    Request was sent to wp-pro email and problem was solved.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Entire Blog Not Showing at All – Public_html dissapeared!’ is closed to new replies.