Support » Plugin: LifterLMS » Enrollment registration isn’t redirecting back to course page

  • Resolved Pyra

    (@prwilliam)


    When students click the Enroll button on a course, fill out their information, and then click register, they are directed to the My Courses page, not the course they are trying to enroll in.

    The courses’ settings are set up to redirect back to the courses themselves. I have also tried setting the redirect back to a custom URL using the course’s URL. That did not work either.

    We used LifterLMS to build an internal onboarding and training system for our employees and it’s house on my company’s private server. So I cannot give access to anyone but I can send you screenshots if you need visuals.

    This is causing a lot of confusion for our students so if someone has a fix, I would really appreciate it.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Natalie

    (@nrherron)

    Hi @prwilliam,

    I’m sorry you’re having this issue!

    When you say you set the redirect on the course setting, do you mean in the access plan settings, at the bottom of the access plan information?

    If you could send us screenshots that would be very helpful to give us a sense of the set up and allow us to check configurations to try and recreate the error on test sites. You will have to send us links to the screenshots through services like: Dropbox, Drive, or Imgur.

    Additionally, if you could send us your system report that would be helpful as well. Before you post it feel free to edit out any site/email information you do not want made public. There is information on the system report here: https://lifterlms.com/docs/how-to-use-the-lifterlms-system-report/ and how to post it here: https://wordpress.org/support/forum-user-guide/faq/#i-need-to-post-code-is-that-okay

    Let us know if you have any questions about finding this information!

    Thanks and take care,

    Pyra

    (@prwilliam)

    Hi Natalie,

    Here is a link to the screenshots: https://www.dropbox.com/sh/4grqdfbwqxkmpxn/AAC6Er1vqG-9lQRUvE5Eojkma?dl=0

    Yes – when I say redirect I mean the the checkout redirect setting in the access plan settings (screenshot 4).

    The screenshots follow the order of what happens:
    1 – the student clicks enroll from the course page
    2 – the student registers
    3 – the student is taken to the student dashboard instead of back to the course they are enrolling in.

    Here is the system report: https://pastebin.com/BFaPZzwV

    Plugin Support Natalie

    (@nrherron)

    Hi @prwilliam,

    I apologize for the delayed response!

    Thank you for the screenshots and system report!

    I noticed two plugins that might be causing this issue. The first is your caching plugin. The main thing with any caching plugin that you want to keep in mind is that you don’t want to cache certain LifterLMS pages or it will cause inaccurate loads: https://lifterlms.com/docs/caching-issues-faqs/

    The other plugin I noticed that could be causing an issue is the Redirection plugin.

    Can you try temporarily disabling these two plugins and see if the issue gets resolved?

    Let us know if this helps or if we should continue troubleshooting!

    Thanks and take care,

    Pyra

    (@prwilliam)

    Disabled both plugins and it did not resolve the issue.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.