Support » Plugin: MooWoodle » Enroll link in email isn’t working

  • Resolved andrewmcd

    (@andrewmcd)


    The email sent by Woocommerce is shown here

    (Sorry it’s a link but I can’t insert an image directly, so the the link above goes to an image capture of the email the user receives)

    The bit where the user should click a link to enroll on a course, what they see is:

    To access your course activity="0"]Introduction to Grasses[/moowoodle]

    In the product short description in Woocommerce, the following was added:
    [moowoodle cohort=”cohortid” group=”groupid” course=”courseid” class=”moowoodle” target=”_self” authtext=”” activity=”0″][/moowoodle]

    So in theory it should work, but I don’t know what could be causing an issue

    Has anyone had similar problems?

    • This topic was modified 2 years, 2 months ago by andrewmcd.
    • This topic was modified 2 years, 2 months ago by andrewmcd.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • I have got the same problem, and before, last year there was no problem at all, it worked fine.
    My learner doesnot get the right website link, nor the username or the password.
    So I would like to know what causes this problem too.
    I have send an email also yesterday about this issue.
    Patricia

    Ambyomoron

    (@josiah-s-carberry)

    If the string is literally:
    [moowoodle cohort=”cohortid” group=”groupid” course=”courseid” class=”moowoodle” target=”_self” authtext=”” activity=”0″][/moowoodle]
    this is not correct. Otherwise, you can ignore my remarks.

    You need to replace “cohortid”, “groupid” and “courseid” with the actual values drawn from your Moodle instance. For example, course=”10″

    You may also need to be careful about the quotes. Have they somehow been replaced with smart quotes, as it appears from your question?

    If you do not use cohorts or groups, then leave the value as an empty pair of quotes, such as cohort=””

    Thanks, I can use the icon from moowoodle dual cube green button for the quote or detect the course as product.
    But is I placxe the follow at the short product description:
    And then I should use the course-10 take the number of 10 at the place of course id:

    [moowoodle cohort=”” group=”” course=”10” class=”moowoodle” target=”_self” authtext=”” activity=”0″][/moowoodle]

    It still doesnot work, I get this as the email for enrolment:
    Username :

    Password : 1Admin@23

    To enroll and access your course please click on the course link given below :

    To access your course activity=”0″]Demo opleidingen[/moowoodle]

    You need to change your password after first login.

    Ambyomoron

    (@josiah-s-carberry)

    Well, I never got it to work either. When I finally realized that version 2 of the plugin requires the user to have a wordpress account and to be logged in, I gave up on it. Version 1.3 of the plugin worked perfectly and never required a wordpress login. I will continue to use version 1.3 until it doesn’t work any more. Then I will figure out what to do.

    It’s a pity the authors of this plugin don’t investigate further all these problems that the users have. All they ever do is publish a new set of instructions (always incomplete) and tell people to follow the instructions.

    @patricia1972
    Dear Patricia,

    All the fields are optional except for the course ID. Please check this video of the course set up:
    https://www.loom.com/share/5d3036f819b14ae3a29c2bc6e115762f

    If you still face any difficulty, we would love to do it directly on your website.

    Thank you.

    @josiah-s-carberry
    Thanks for your helping hand. We have made this video if you need any help for now: https://www.loom.com/share/5d3036f819b14ae3a29c2bc6e115762f

    In the next version, the users won’t have to deal with the shortcode anymore.
    We are working on it.

    Thank you.

    Thread Starter andrewmcd

    (@andrewmcd)

    The course id, I’m getting by hovering over the hyperlink to the course in the list of available courses in Moodle and using that, leaving groupid and cohortid empty and it still displays the same mangled link in the email

    I’ve watched the loom video and I’ve followed that process ok, it was useful to see if I’d missed anything

    Thread Starter andrewmcd

    (@andrewmcd)

    Found the problem, it needs the language in WordPress to be set to English(US)

    I had it set to UK English

    Digging around posts on the forum got me to it

    So now the broken email link is fixed, and the sign up button works…

    But now I’m on to the problem of being registered as an admin account in Moodle,, which seems to be a common topic on here

    So this problem is resolved at least, and onto the next one….

    @patricia1972 Thanks for the help.

    @andrewmcd We will try to fix the language problem in our next update.

    Thank you.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Enroll link in email isn’t working’ is closed to new replies.