WordPress.org

Support

Support » Plugins and Hacks » Responsive Column Widgets » [Resolved] Too much of inline styles

[Resolved] Too much of inline styles

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author miunosoft

    @miunosoft

    Hi,

    I don’t fully understand your problem.

    To shorten the plugin’s stylesheet, you can check the option Minify CSS Code in the General Options tab.

    Hope it helps.

    black40

    @black40

    Thank you for your response.

    The problem is that the plugin inserts inline <style> code to the page (see the code of the page, it begins at the row 133). Then I have problems with SEO analysis due to huge amount of inline CSS code that should be inserted to separate CSS file(s).

    <style type='text/css' class='style_responsive_column_widgets_65552fa185094c92440213b509994cf4'>@media only screen and (max-width: 600px) {
     .responsive_column_widgets .responsive_column_widgets_column_600_element_of_1 { width:100%; clear: left; margin: 1% 0 1% 0; display: block; float:left; }
     .responsive_column_widgets .responsive_column_widgets_column_600_element_of_2 { width:49.2%; display: block; float:left; }
     .responsive_column_widgets .responsive_column_widgets_column_600_element_of_3 { width:32.2%; display: block; float:left; }
     .responsive_column_widgets .responsive_column_widgets_column_600_element_of_4 { width:23.8%; display: block; float:left; }
     .responsive_column_widgets .responsive_column_widgets_column_600_element_of_5 { width:18.72%; display: block; float:left; }
     .responsive_column_widgets .responsive_column_widgets_column_600_element_of_6 { width:15.33%; display: block; float:left; }
     .responsive_column_widgets .responsive_column_widgets_column_600_element_of_7 { width:12.91%; display: block; float:left; }
     .responsive_column_widgets .responsive_column_widgets_column_600_element_of_8 { width:11.1%; display: block; float:left; }
     .responsive_column_widgets .responsive_column_widgets_column_600_element_of_9 { width:9.68%; display: block; float:left; }
     .responsive_column_widgets .responsive_column_widgets_column_600_element_of_10 { width:8.56%; display: block; float:left; }
     .responsive_column_widgets .responsive_column_widgets_column_600_element_of_11 { width:7.63%; display: block; float:left; }
     .responsive_column_widgets .responsive_column_widgets_column_600_element_of_12 { width:6.86%; display: block; float:left; }
     .responsive_column_widgets .responsive_column_widgets_column_600_element_2_of_2 { width: 98.4%; }

    etc.

    But if I check “Minify CSS Code” in general settings, the real amount (size in kB) of the code is the same as unchecked. The <style>code is only without blank spaces (without format).

    Is there any easy way to hide (or insert) these ca. 200 rows of inline style code into separate CSS file?

    Thank you very much and I apologize for complicated explanation 🙂 but I don’t know how to describe it better 🙂

    Plugin Author miunosoft

    @miunosoft

    I see what you mean now.

    If you say inline styles, it usually refers to the style attribute inside tags. ( http://webdesign.about.com/od/css/qt/aatypesofcss.htm ) You are talking about embedded styles in the head tag.

    The plugin generates CSS rules dynamically based on the used parameters. That is why embedded styles are used. I may consider adding an option to use external style sheet even for the dynamic rules but the response time will be slow.

    To work around your problem, in the General Options tab of the setting page, there is an option named Timing to Load. You may try changing it to When the first widget box is loaded. so that the embedded styles won’t be loaded in the head tag.

    black40

    @black40

    Thank you very much.

    It works! The problem has been solved 🙂

    Plugin Author miunosoft

    @miunosoft

    Glad to hear that!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Too much of inline styles’ is closed to new replies.
Skip to toolbar