Support » Plugin: Google Tag Manager for WordPress » Enhanced Woocommerce Tracking not working

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi,
    if could help, this is the solution I found thanks to the plugin author:

    I had to open the tag named “GA – E-commerce impressions” and remove the GA variable into the “Tracking ID” field that I wrongly set because I already did it in the Google Analytics settings.

    I had your same problem and now I can see the ecommerce events!

    Thread Starter keramikoch

    (@keramikoch)

    Hi @angeloarlotta ,

    do you mean this one?
    https://ibb.co/mRbsGLD

    I have set the variable for
    GA – Pageviews
    GA – Events – Ecom Events
    GA – Events – product impression tracking ( I think this is the one you mean)

    But why is a problem to use the variable many times?
    And what do you enter instead of this variable, the tracking ID itself ?

    Thank you in advance, this problem is really bugging me and took me already hours to find a solution.

    I know, it took me more than one month until I found this solution.
    From your screenshot it seems you correctly set this tag and did non repeated twice the GA variable so maybe my solution won’t help in your case. Try asking support on this facebook group, maybe you will find a solution here: https://www.facebook.com/groups/329145737601165/

    Thread Starter keramikoch

    (@keramikoch)

    I feel you ..

    I applied in this group, I will certainly try that. But can you explain me what you meant with:

    “I had to open the tag named “GA – E-commerce impressions” and remove the GA variable into the “Tracking ID” field that I wrongly set because I already did it in the Google Analytics settings.”

    What do you mean by “google analytics settings”? Is this a tag or some setting in google analytics itself?

    • This reply was modified 1 month, 3 weeks ago by keramikoch.

    I just insert the GA variable twice in this field https://ibb.co/VLCwdr8
    This variable is already expressed in GA so it’s not necessary to insert it again here.
    For that reason I wasn’t able to get ecommerce events in GA but they was triggering into GTM.
    But as I saw into your screenshot you didn’t fill this field.. so I guess it’s not your case unfortunately..

    I am having exact same issue. All tags, events and datalayer firing as they should, with object name and so on. Yet nothing shows up in e-commerce reports inside GA4. Only purchase value. However I am using GA4 and followed this video for help in setup:

    *EDIT: For me, it just might be only a typo. I will wait a few days to let it populate the data again.

    • This reply was modified 1 month, 3 weeks ago by madjedo.
Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.