Support » Plugin: W3 Total Cache » Enhanced disk caching not working with no errors; page cache empty

  • Plugin installed, only disk caching enabled. However, page cache never has any pages in it (checked folder on disk). Logs show that plugin is fetching pages, but pages never appear in cache. No errors shown on page, no errors in logs. Tuned on page cache debugging, but no debug info appearing in pages. It’s almost like the plugin isn’t hooking into wordpress correctly.

    I am seriously considering trying another plugin, the only reason I have not switched is that is is a regression; it worked before and then randomly stopped working, probably after an update. Also, I checked the permissions and what not, it’s all fine. I also reinstalled the plugin and deleted the settings; same issue.

    Only possible problem I can see is that the blog is in a subdirectory instead of on the root. There could be a bug related to detecting that properly.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Update: it seems to only be caching feeds. Everything else seems to just bypass caching and never end up in the pgcache folder. Very strange. Any advice or should I just can this plugin and install something else?

    My blog is a subdomain, and I can not activate “disk enhanced” because then causes Error 403. Check it by testing in, then I see Error 403 in the ‘Repeat View’.

    Frederick already know about this incident and are trying to solve.

    The problem here is that I get NOTHING AT ALL. Doesn’t matter if the plugin is installed, deleted, enabled, disabled, etc. WordPress behaves like the plugin doesn’t exist. I can’t get it to output any debugging information and nothing generates error messages. If I got a 403 I would be happy because that gives me something I can track down. I have been getting nada which is why it is so frustrating.

    I can see in the log files that the plugin is grabbing pages for the cache (Total Cache user agent), but nothing ever appears in the page cache directory and no debugging information is inserted into the pages even though page cache debugging is enabled…..

    Edit: tried webpagetest, no error at all. pgcache dir empty except for one cached feed (?).

    Seems to have something to do with the theme (wtf?!??). Tried a fresh install on the same computer with the same config. Installed w3tc, worked. Copied in theme ‘eos’, fails. No errors, empty page cache. I’m at a loss….I suppose I will just switch to supercache then, since really the only feature I care about is the enhanced disk caching, the rest of it really isn’t all that useful to me right now…

    Update: with Super Cache installed and set up properly, ab went from ~10 pages/sec to ~450 pages/sec. That’s what I’m talking about…..

    I can confirm the problem with the theme ‘eos‘. W3TC does not work at all with this theme. W3TC ist activated, but it does anything, even the footer (“compresssed by W3TC…”) is missing. I didn’t have this problem with prior versions.

    Great. This is a regression in W3TC as far as I can tell since it worked in previous versions. Unfortunately, due to the lack of error messages and log entries, I am unable to assist in debugging this issue.

    Is there a way to log the cache entry creation process to a separate file? Something like that could be instrumental in solving issues such as these. Right now my blog is running just dandy with WP Super Cache until this issue can be resolved…

    Plugin Author Frederick Townes


    Did you disable all other plugins and test again? What happens if you switch to twentyten theme temporarily?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Enhanced disk caching not working with no errors; page cache empty’ is closed to new replies.