Support » Plugin: Enhanced Category Pages » Enhanced content not showing

  • Resolved wpuser

    (@forinn)


    Dear Cip,

    The plugin looks promising and nice, just what I needed, so I installed it.
    Unfortunately, I have problems getting the enhanced content to actually show on the webpage. It gives me only the resume (excerpt) and not the enhanced content.

    I tried to follow up the installation instructions, but since I have neither category.php nor taxonomy.php, I was not sure where to put the code. I tried different files, but none seemed to work. May be the case my theme is overrulling/forbidding this plugin from working, but I have lots of plugins running succesfully without the theme interfering, so that chance would not be big. My theme is Virtue Premium.

    Please help me get this working. Thanks in advance.

    https://wordpress.org/plugins/enhanced-category-pages/

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author cip

    (@cip)

    Hi!

    Thank you for choosing our plugin and finding it useful.

    Your question is specific to the theme you are using and can be fully answered only with access to that plugin code. Unfortunately we don’t have access to it.

    Could you identify the file in your theme that is responsible with displaying the category page?

    Thank you!

    PS: we have been away, so please accept my apologies for the delayed response.

    Dear cip,

    I’ll zip the whole content of my theme folder if you can give me a email adress I can send it to?

    Thanks in advance.

    Greetings,

    I am having also an issue with getting Enchaned category pages displayed.
    I am using this theme: http://themeforest.net/item/handy-handmade-shop-wordpress-woocommerce-theme/11048978 and Woocommerce. I am looking to edit the product category pages.

    I tried adding the code into category.php but that is not working for me. I am not too sure where to put it to begin with. I tried it on several spots but so far no luck. There is not a separate product category template as far as I can tell.

    Below is the code from the orginal category.template. Any clue how to solve this?

    Kind regards,
    Gigi

    <?php
    /**
     * The template for displaying Category pages
     *
     * @link http://codex.wordpress.org/Template_Hierarchy
     *
     * @package WordPress
     * @subpackage Twenty_Fourteen
     * @since Twenty Fourteen 1.0
     */
    
    get_header(); ?>
    
    <?php // Check if site turned to boxed version
    	  $boxed = ''; $boxed_element = ''; $row_class = '';
    	  if (get_option('site_layout')=='boxed') {$boxed = 'container'; $boxed_element = 'col-md-12 col-sm-12'; $row_class = 'row';}
    ?>
    
    <div class="breadcrumbs-wrapper">
    	<div class="container">
    		<div class="row">
    			<div class="page-title">
    				<?php printf( __( 'Category Archives: %s', 'plumtree' ), single_cat_title( '', false ) ); ?>
    			</div>
    			<?php if ( function_exists('pt_breadcrumbs') ) { pt_breadcrumbs(); } ?>
    		</div>
    	</div>
    </div>
    
    <?php if (!$boxed || $boxed=='') : ?><div class="container"><?php endif; ?>
    	<div class="row">
    		<?php if ( pt_show_layout()=='layout-one-col' ) { $content_class = "col-xs-12 col-md-12 col-sm-12"; }
    			  elseif ( pt_show_layout()=='layout-two-col-left' ) { $content_class = "col-xs-12 col-md-9 col-sm-9 col-md-push-3"; }
    			  else { $content_class = "col-xs-12 col-md-9 col-sm-9"; }
    			  /* Advanced Blog layout */
    			  if (get_option('blog_frontend_layout')=='grid' || get_option('blog_frontend_layout')=='isotope' ) {
    				  $content_class .= ' grid-layout '.esc_attr(get_option('blog_grid_columns'));
    			  }?>
    		<div id="content" class="site-content <?php echo esc_html($content_class); ?>" role="main">
    
    			<?php if ( have_posts() ) : ?>
    
    				<?php
    					// Show an optional term description.
    					$term_description = term_description();
    					if ( ! empty( $term_description ) ) :
    						printf( '<div class="taxonomy-description">%s</div>', $term_description );
    					endif;
    				?>
    
    			<div class="arcive-pages-content">
    
    			<?php
    					// Start the Loop.
    					while ( have_posts() ) : the_post();
    
    					/*
    					 * Include the post format-specific template for the content. If you want to
    					 * use this in a child theme, then include a file called called content-___.php
    					 * (where ___ is the post format) and that will be used instead.
    					 */
    					get_template_part( 'content', get_post_format() );
    
    					endwhile;
    
    					echo "</div>";
    
    					// Previous/next page navigation.
    					$blog_pagination = esc_html(get_option('blog_pagination'));
    					if ( ($wp_query->max_num_pages > 1) && ($blog_pagination == 'infinite') ) : ?>
    						<span class="pt-get-more-posts"><?php _e('Show More Posts', 'plumtree'); ?></span>
    					<?php else : ?>
    						<?php pt_content_nav(); ?>
    					<?php endif;
    				else :
    					// If no content, include the "No posts found" template.
    					get_template_part( 'content', 'none' );
    
    				endif;
    			?>
    		</div>
    
    <!-- #content -->
    		<?php get_sidebar(); ?>
    
    	</div>
    <?php if (!$boxed || $boxed=='') : ?></div><?php endif; ?>
    	</div><!--.main -->
    <?php get_footer(); ?>

    Plugin Author cip

    (@cip)

    @wpuser Please send your template to our support email: enhanced.category.pages@gmail.com

    Thank you!

    Plugin Author cip

    (@cip)

    @digigigi

    By calling $enhanced_category->setup_ec_data(); the current queried term is identified by using (in order):

    1. get_query_var("taxonomy");
    2. get_query_var("term");
    3. get_cat_id(single_cat_title("", false));

    This is designed to setup current post to the corresponding enhanced category custom post.

    Alternatively, if you have the id of the category (let’s say in $cat_id) you can use calling setup_ec_data using id param:

    $enhanced_category->setup_ec_data($cat_id);

    Looking at your code, the best promising place is just above line:

    <?php if ( have_posts() ) : ?>

    Of course tests should be done on live code.

    Cip, I’ve tried to sent you the email but the e-mail address is not working, I’m getting the mail back. I’ve tried to resend it via WeTransfer. Can you please let me know if you received it?

    Plugin Author cip

    (@cip)

    @wpuser, we have received your archive and shall run some tests this week.

    Plugin Author cip

    (@cip)

    Hi @wpuser!

    We have checked and identified the files to be edited in Virtue Premium theme in order to enhance the category pages as desired.

    Here they are (click to see the diff):

    1. archive.php
    2. templates/page-header.php

    Note: A very good resource for any WordPress developer/designer/power user is the WordPress Template Hierarchy. As you could see, there, unless category.php file is found, then WordPress usese archive.php, as it is the case with Virtue Premium theme.

    PS: You can support open source community with a donation: click here to donate or/and you could share your experience with our plugin: rate ECP plugin.

    Plugin Author cip

    (@cip)

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    *Drinks coffee, coffee is my friend*

    Hi @cip thanks for the support (honest!) and you’ve gone above and beyond for supporting your user. That’s very, very cool especially when you took all that time to demonstrate where the problem lies outside of your plugin.

    *Raises coffee mug in heartfelt salute*

    But a small side note here: Please don’t use URL shortners. They make me itch and also make me suspicious. Here’s why. Your link looks like this <a href="https://goo.gl/Psvq6d">rate ECP plugin</a> which expands to this.

    https://wordpress.org/support/view/plugin-reviews/enhanced-category-pages?rate=5#postform

    See the ?rate=5 part? That filter gives people the wrong impression. Don’t do that, I’ve replaced the link with the right one without the rating filter. That’s gaming the system and is really frowned upon.

    EDIT: Actually the ?rate=5 is fine and 100% alright. I made a mistake about that part, my apology. But I still don’t like shortlinks. 😉

    Also the tin foil hat network security person in me cringes at short links because it’s too easy to abuse them with redirects to other places before sending the user on to the actual URL. I’ve updated all of the URLs in that post.

    Other than that, I know your hard work is appreciated and much thanks. 😉

    Hi cip,

    Thanks for the great support and the instructions. I followed them all, but for some reason the enhanced content is still not showing 🙁

    What could have gone wrong?

    PS: thanks for the handy url! I already figured that out via another topic in this forum, with different link. But this one comes more in handy, thanks!

    Anyone? Please? Still waiting for a solution.

    You have marked this topic als resolved, but it is NOT resolved. I haven’t heard back from you anymore. Please help me.

    Plugin Author cip

    (@cip)

    Hi!

    Please provide a diff your files and maybe a link to your dev server.

    The changes worked on our support server and this it why the thread was marked as resolved. There must be something specific to your setup or some wrong changes.

    Let us know!

    I can give you FTP access, but what would you need it for? Because I did exactly as you instructed and I did not change any files other than the usual updates the theme has. I sent you an exact copy of my theme.

    If you still need it, let me know and I will mail it to you. Or would you rather have an admin account to my wordpress login?

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Enhanced content not showing’ is closed to new replies.