Google Language Translator
English Translation bug (2 posts)

  1. jawhite1
    Posted 1 year ago #


    I'm having an issue with the English translation button when you first load the page. If you click on the English translation flag when you first enter the page, the language will be translated to Afrikaans, instead of just maintaining the default English.

    Is this a known bug or is this exclusive to our site?

    You can check out the issue at http://www.catsimulators.com and click on the U.S. flag in the footer.



  2. Rob Myrick
    Plugin Author

    Posted 1 year ago #

    Hi jawhilte1,

    Yes, I totally understand your frustration with this. I'm still trying to figure out a good way to disable this problem, although I've only heard one or two complaints about it.

    Try going into your settings panel located at "Settings > Google Language Translator", and then check the Multilanguage Mode setting.

    That might help because you can click on your default language numerous times without toggling the languages.

    Let me know how it goes.


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Google Language Translator
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.