Support » Plugin: Drag & Drop Featured Image » Endless Spinning Wheel

  • I noticed that I drag and drop my featured image. What happens is that the wheel starts spinning but never stops. I eventually hit ‘save’ on the post and then it turned out that the image was actually saved correctly. Then I tried it again and it was not ready with uploading – but there is no way for me to see if it is done uploading or not.

    Anybody experiencing this as well? Any way to fix this? Thanks,

    Chris

    https://wordpress.org/plugins/drag-drop-featured-image/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi Chris I had the same problem. I tracked the Ajax request that is send while uploading a new image. In the answer you might receive an error like so:

    getimagesize(): http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /homepages/u56924/beta/wp-content/plugins/drag-drop-featured-image/index.php</b> on line 495

    As you can see the problem is that my server (and I bet your server as well) by default disallows loading files, which the function getimagesize() does by using fopen().

    So what you could do is upload a php.ini file to your server with the following content, for each folder starting from your wordpress main-folder to the plugin folder…

    But as you might not need the image-size information I suggest editing the plugin index.php like this (line 493):

    // Get image sizes and correct thumb:
    $croppedImage = wp_get_attachment_image_src($attach_id, 'full');
    //$imageDetails = getimagesize($croppedImage[0]);
    // Create response array:
    $uploadResponse = array(
    'image' => $croppedImage[0],
    //'width' => $imageDetails[0],
    //'height' => $imageDetails[1],
    'postID' => $post_id
    );

    Now the endless spinning problem is solved but as wordpress now uses responsive images the next problem is, that the srcset-attribute migh override the src-attribute, so you might get the old thumbnail if there is one. So you may want to add the following after line 421:

    imageObject.removeAttr('sizes');
    imageObject.removeAttr('srcset');

    This is just a quick and dirty method as you disable the image being responsive but never mind. 🙂

    Hope this helps to you as well.

    Hey guys,

    I’ve been swamped, but just updated the plugin assets with new images and updated the readme to reflect the latest version of WordPress. This is a serious problem, and I’m thinking it might be something I should actually consider changing in the plugin itself.

    I’m going to look into it and might publish a fix for this soon.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Endless Spinning Wheel’ is closed to new replies.