Support » Plugin: WooCommerce » Endless Spinning Wheel

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Amanda

    (@amandasjackson)

    This kind of problem is usually caused by either a conflict with your theme or with another plugin.

    The best way to determine if the issue is being caused by a theme and/or plugin is to temporarily switch your theme to Storefront and disable all plugins except for WooCommerce. If you can install plugins, install Health Check. On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you while you’re logged in to that session without affecting normal visitors to your site. Note that Health Check may not count Storefront as a default theme, so you can also use Twenty Seventeen as well.

    If that resolves the issue, then one-by-one you can switch back your theme and re-enable your plugins, testing in between, until you find the one causing the conflict.

    NicheLabs

    (@allennichelabs)

    I disabled all plugins except for Woocommerce.
    I installed Storefront and set that as the theme.
    I went through each variation, selecting a value, and again, as soon as I select a value for the last variation I get the spinning wheel and it just sits there.

    NicheLabs

    (@allennichelabs)

    I just moved everything over to a new, dedicated server and still getting the same issue. It appears to be some limitation on the number of variations allowed since, as I mentioned before, just a difference of 1 variation causes it to fail.

    I’ve tried disabling all other plugins, changing the theme to Storefront, increasing the amount of memory allowed for both the server and for WordPress.

    I’ve also adjusted the following PHP settings with a php.ini file:
    max_execution_time = 300
    max_input_time = 120
    memory_limit = 1024M
    post_max_size = 128M
    upload_max_filesize = 128M
    max_input_vars = 2000

    Nothing seems to help. It works with the one import file but fails with the other, with only one more attribute selection option.

    I really need this resolved as I still have other attributes I need to add in addition as these.

    NicheLabs

    (@allennichelabs)

    It appears to be some sort of limit on the sum total of variation options. I took the import file that worked and added one more option to a different variation (Night Play Lights).

    After importing the file I get the same results when selecting variation options.

    NicheLabs

    (@allennichelabs)

    I’ve located a solution, I was correct in that it had to do with the sum total of variations. It appears the magic number is 30.

    I found this:
    https://iconicwp.com/blog/modify-ajax-variation-threshold/
    When your variable product has more than 30 variations, WooCommerce starts to use ajax to load your selected variation. This changes the way the dropdown fields work – where before you could select some options and others would become unavailable/disabled, now you have to select all options before finding out the variation you selected is not available.

    Fortunately, as with most things WooCommerce, you can modify this setting. Try adding this to your theme’s functions.php file:

    function iconic_wc_ajax_variation_threshold( $qty, $product ) {
        return 50;
    }
    
    add_filter( 'woocommerce_ajax_variation_threshold', 'iconic_wc_ajax_variation_threshold', 10, 2 );

    This means ajax will only kick in when there is more than 50 variations. You can adjust this accordingly.

    On my site I changed it to 150.

    Now I don’t understand why Ajax would lock up the site and never complete when I was just 1 variation over the limit. But I’ve tried it with my original import tile with 48 attributes and it works. Now on to add the rest of them….

    Plugin Support Amanda

    (@amandasjackson)

    Thank you for letting us know you have been able to find a resolution.

    I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

    I had the spinning wheel problem on my WP 4.9.6 site and I’m using the Salient Theme.
    After checking I discovered that the wrong editor plugin was active. With Salient there can be confusion between WP Bakery Visual composer and Salient Visual composer , both seem to be of similar origin. Disabling WP Bakery and activating Salient Visual Composer fixed the problem. Its not clear to me how a visual editor can completely block the site from rendering.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Endless Spinning Wheel’ is closed to new replies.