Support » Plugin: Ultimate Member – User Profile, User Registration, Login & Membership Plugin » Endless Redirect with Ultimate Members Plugin

  • I would like to set up my site so a user must log in before seeing any content. I’ve set up restricted access to all pages to the site. When accessed without logging in, then the page will redirect you to the log in page.

    However, it seems UM causes wordpress to timeout with the following error:
    Details
    There were too many redirections.
    Error Code: INET_E_REDIRECT_FAILED

    site works when UM is disabled.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 23 total)
  • Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @melkwok,

    Can you please clarify where did you set access restriction?
    If you want to restrict entire site you can set “Global site access – Site accessible to logged in users.” in Ultimate member -> Settings -> Access and restriction content tab.
    Make sure that your login/register pages are accessible to logged out users.

    Please try to do a conflict test so we can rule out conflicts with other plugins or your theme and see if this issue goes away. Here is the doc on how to do a conflict test if you are not sure how to do it.

    Regards.

    Thread Starter melkwok

    (@melkwok)

    Hi,
    The pages I’m trying to restrict are the products page and the shop created by WooCommerce.

    I’ve followed your instructions and removed all individual page level restriction, and used Global Site Access instead to restrict my site.

    While the endless redirect has been resolved. The current issue now is… no matter what link I click on from the menu (Theme Used : StoreFront), it redirects me to the Member details page. Only situation where the links stop redirect is if I’m logged in as an admin.

    Thank you,
    Melody

    Also experiencing endless redirect loop (cannot load page) issues with UM 2.x Registration form. Site using in conjunction with Theme My Login (v64 or v7), however disabling TML doesn’t eliminate the issue with Registration. Registration page worked before 2.0 upgrade, but there doesn’t seem to be a UI to resolve 1-to-multiple (legacy) UM Community roles. Website is using HTTPS (Really Simple SSL), but disabling the SSL redirect does not correct the issue so it doesn’t seem to be an issue with the SSL redirect.

    Thank you,
    Glenn

    • This reply was modified 3 years, 1 month ago by gwizweb4. Reason: signature

    I am experiencing the same issue. I have disables all plugins and the issue persists.

    I can only view the site if I am logged in to WordPress. Which kind of defeats the purpose of having a membership plugin.

    Chrome: [site] redirected you too many times.
    Firefox: The page isn’t redirecting properly
    Safari: There were too many redirections

    Not sure what is causing the issue. I restricted access to a number of pages on my site, but not the home page or other main pages.

    If I can’t resolve this issue quickly, I’m moving on to another solution.

    I also have this issue. Help

    Hey guys

    I had the same problem and this worked for me:

    – Go to settings in UI
    – Make sure your logout page isn’t set to your homepage

    Hope it works, made an account just so I could share this with you.

    Has anyone been able to resolve this issue?

    I upgraded from 1.3 to 2.x (and PHP 5.x to PHP 7.2) and am getting a redirect loop when logging out. Nothing in the error log.

    My logout page is /logout and is not restricted, and the site is also not restricted (global access). And with what @dumbstuff said, my logout page isn’t set to my homepage so that isn’t the case.

    I’m using this with the Avada theme and WP 4.9.9. No multisite.

    Version 2.0.38 | Af Ultimate Member
    Avada 4.0.3

    I was pointing ALL pages to something and NON of them to HOME,
    This worked

    Hi guys, I had the same issue, @dumbstuff got it right.

    – Go to settings in UI
    – Make sure your logout page isn’t set to your homepage

    Well done @dumbstuff ! Mine works fine now!!! 🙂

    I have an issue with Ultimate user. Other roles apart from the admin, has no access to the dashboard, even after granting access to the specific role. It keeps saying “sorry you have no access to this page. Works well after the plugin is deactivated.

    Don’t set logout page as the home page as suggested by @dumbstuff

    i got the similar issue when i restricted some pages. loop redirects.

    Same issue here when logged in as admin trying to access member profiles.

    Also the issue on trying to access member profiles

    My issue was when I clicked View or View profile.

    After debugging, I found these were trying to go to certain page ID which turned out to be the User page which had got changed to Draft status rather than Published.

    The field in settings for the User Page was showing as my home page but it was still trying to access the draft User Page. Once I published the User page and changed the User Page setting to this page, everything worked

Viewing 15 replies - 1 through 15 (of 23 total)
  • You must be logged in to reply to this topic.