WordPress.org

Support

Support » How-To and Troubleshooting » endless redirect loop when trying to access admin system

endless redirect loop when trying to access admin system

  • datasmith
    Member

    @datasmith

    We’ve had a stable blog running for several months now. Yesterday attempts to access the admin system began failing, returning endless redirect loop messages in Firefox. Looking at the process through the TamperData plugin I’m seeing it bouncing with 302 status codes between wp-login.php and wp-admin/ anytime I try to hit wp-admin.

    Other pertinent bits:

    • The front end of the blog, all the public content, works fine, it’s only the admin side which is effected
    • The site is not using .htaccess redirects and the site url setting matches the blog url setting.
    • Nothing on the server itself has changed and other WP sites hosted on the same server work just fine.

    The other redirect problem related posts I’m seeing talk about conflicts between the site and blog url or problems where the admin side works but not the front end.

    Any suggestions on where I should be looking for the source of this?

    Thanks.

Viewing 15 replies - 1 through 15 (of 21 total)
  • slojo
    Member

    @slojo

    Hi Datasmith

    I am having the exact same problem. Oddly enough, I’ve asked someone from off-site to try to login using my details and it seems they are able to.

    I am wondering if it could be some kind of FF caching issue.

    datasmith
    Member

    @datasmith

    That’s pretty weird, slojo. I think I can rule out a browser issue in my case, because the client reporting the problem is using IE.

    Before you started having the problems, had you made any changes to the settings, themes, plugins, or anything? What version are you running?

    datasmith
    Member

    @datasmith

    UPDATE: It looks like wp-admin isn’t reading the user cookie properly, though everything seems to be correct in the code. Any ideas?

    slojo
    Member

    @slojo

    I guess my situation is a bit unique…I managed to cause this problem during attempts to fix the .htaccess problem I’ve been having (see my post from a few hours ago).

    I’ve just checked IE and I can access the admin login screen there…

    Samuel Wood (Otto)
    Keymaster

    @otto42

    Couple of things to try. Do ’em both.

    1. Clear all browser cookies.
    2. Change the secret keys for the system. This will invalidate everybody’s cookies, so they’ll have to log in again. Description of how to do it here:
    http://wordpress.org/support/topic/170987

    datasmith
    Member

    @datasmith

    Thanks, Otto42, but they’re running 2.1.3 and the secret key thing didn’t come along until 2.6

    Samuel Wood (Otto)
    Keymaster

    @otto42

    Oh. Well, I have no idea then. Upgrade. 😛

    doodly
    Member

    @doodly

    I’m having the same problem, with an install of 2.5 that’s been working perfectly for weeks. Suddenly I get the login loop this morning.

    I’ve tried multiple browsers and clearing cookies and no joy – any suggestions?

    (I thought I just posted this but it’s not appearing – if we end up with duplicate posts, I apologize)

    uptowngal
    Member

    @uptowngal

    Hi Otto42,

    Need a bit of guidance. I upgraded to WP2.6.1 once it came out. But my blog got hacked by some spam injection bot on Saturday and upon checking, I realised my secret key was not updated to what it should be in 2.6.1 (was using the one for WP2.5).

    I thought everything was resolved after I cleaned up my wp-config.php and added in the correct secret key – i.e. my blog is viewable, and I can post entries using Windows Live Writer.

    However, I wanted to go into my admin panel to approve some new comments today and that’s when I realised the wp-login.php just keeps looping. At first I thought I somehow forgot my password so I went to reset it… but it doesn’t work. I’m still looping at that page.

    Could you help please? I’ve tried all the methods I can find on this forum – from deleting cookies, to making sure my siteurl is the same as my home value, etc.

    Sorry if my questions seem silly but I’m new to this and am trying to understand as much as I can of what I read.

    Thanks in advance!

    (Btw, my blog at http://uptowngal.org/blog if that’s of any help.

    mondolizzie
    Member

    @mondolizzie

    It is happening to me too. I cannot log in. I added the secret keys via ftp, but cannot access my admin services. I am getting the endless loop as well. Help!

    mondolizzie
    Member

    @mondolizzie

    I disabled wp_useronline and it worked for me to log in. It seems it is a different plug in for everyone. My suggestion is to disable them one at a time using FTP and see which one is your culprit.

    doodly
    Member

    @doodly

    Yep, with the tips in this thread I went and deleted a redirect plugin (that had been working fine for ages, but anyway . . .) and I can log in fine now. So it looks like that might be a place to start for some folks.

    Cheers for the pointers.

    uptowngal
    Member

    @uptowngal

    Mondolizzie!!! Thank you!! For me, it was disabling the WP automatic upgrade plugin!! Can enter the admin panel now! Yippee!!! Thanks everyone who contributed!

    (Doodly – like u, my plugin always worked previously. SIGH!!)

    Have a good week ahead folks!

    ghollingsworth
    Member

    @ghollingsworth

    I had the same thing happen, fixed when I removed the google sitemap generator plugin. Looks like I need to find a new sitemap plugin.

    datasmith
    Member

    @datasmith

    The only solution I was able to find was upgrading. It bugs me that I don’t know why things went wonky but at least they’re working currently.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘endless redirect loop when trying to access admin system’ is closed to new replies.