Support » Plugin: Paid Memberships Pro » Endless problems with PMPro

  • Resolved ladoquin


    I am sad to say, that my experience with PMP’s Paypal transactions is anything but possitive. After errors creating levels and figuring out that every field needs to have a value of 0 even though the checkbox says don’t use those fields I was finally able to get to a point of testing the plugin. I then found error after error:

    1. Free level raises error as it tries to convert a “” string into an integer when there is no discount code.

    2. When testing PayPal express, I noticed there were no amounts shown in Paypal for the re-occurring payments are not reflected anywhere. Upon accepting of the payment I get re-directed back to the PMPro in my site and the confirmation shows a message of “The PayPal Token was lost”. On checking the url I can see the review and token value are present. I then proceeded to check the order table and found there was not even a record for the order present.

    3. Then testing PayPal standard I noticed that there are still no orders records created.

    On investigation I noticed the insert statement for the pmpro_membership_orders was unable to find the UserId and the CertificateID. these fields are both being populated with “” and this causes an error when trying to convert to int.

    I am also testing out another membership/subscription plugin, it has none of these problems.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Im sorry to hear you are having these issues, remember PMP is fairly new in the making, and people like us testing and using it, is what makes it better. So the creator can correct these issues. You should try and use this with STRIPE gateway thats the gateway im using and its PERFECT ! not to mention, you know Jason the owner has a paid support and help on his site, i think its like $99 bucks for the year, unlimited help and support and etc. that will give you priority help with issues as you mentioned before if you really want to use the paypal. Im STRIPE all In ! Just wanted to buzz you this.


    I really love the plugin in terms of the features it offers. I’m just a little reluctant to pay for something that might not end up working in the end. I have no problem paying for something if I know it’s going to do the job for me that is needed.

    With regards to stripe I am in South Africa so the only option we really have is PayPal so I need that to work.

    my I ask what version of PMP do you have installed. 1.5.8 there has been a lot of updates in this latest version? TIP: download it direct from wordpress

    I noticed if you download it from the website of the creator its still the older version.

    Yes I am running 1.5.8. My wordpress site asked me to do the update which i did just the other day.

    @ladoquin new update for pump there was a Paypal fix as well update the plugin and re test

    @ladoquin new update for pmp there was a Paypal fix as well update the plugin and re test ((( re post darn ipad has a mind of its own on spelling)

    Thanks for the response. Jason has found that all the issues were in fact due to bugs in the plugin that became apparent on a Windows OS. He seems to have corrected the issues.

    Great ! 🙂

    Plugin Author Jason Coleman


    Ladoquin, one of our customers was having similar issues.

    Are you running on a Windows/IIS server? Do you have MySQL “strict mode” enabled?

    Turning off “strict mode” might fix this. Otherwise, we’re working to resolve these DB issues in version 1.6 which is coming out soon.

    Sorry you had trouble. We don’t typically test on a lot of Windows setups and rely on people like you to discover these things and bring them to our attention. 🙂 So thanks for doing that.

    Thanks for the reply. I look forward to getting the next version of the plugin to test.

    Same here on a system working until yesterday. What happening?
    (Linux, tried both WP 3.5.1/3.5.2, latest version of PMP)

    Got the issue: it’s a bug in the latest version ( “The PayPal Token was lost.”

    I’m using the 1.6.1 version right now, after a db cleaning, everything works fine.

    Hint: After a db cleaning and a fresh install of the 1.6.1 pmp plugin, you can also upgrade it to the latest It works.

    I too am getting the “PayPal Token was lost” message when clients try to register.

    I am using the version. I’m not that tech savvy and have found this plugin quite frustrating after having problems with not being able to create membership levels.

    Some assistance would be greatly appreciated.

    How can I get version 1.6.1 to try?

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Endless problems with PMPro’ is closed to new replies.