WooCommerce - excelling eCommerce
Endless loading spinner checkout (12 posts)

  1. Allurelle
    Posted 1 year ago #

    Hi guys,

    I have a huge problem with my checkout page, namely there is an endless loading spinner and I can't choose for another payment method. The problem occurs on different browsers: Google Chrome, Firefox, Dolphin, Safari, Internet Explorer, on the web, tablets and mobile phones. I've tried to change the first method of payment from Paypal to Ideal (sometimes this works, but on the mobile phones the checkout still doesn't work). I have the newest theme version, I also tried to disable and enable all plugins, but still nu solution. Also the system of woocommerce says I don't have any errors or problems.

    I hope someone can help me out, because my customers can't pay right now! My website: http://www.allurelle.nl

    Kind regards!


  2. lorro
    Posted 1 year ago #

    I visited your site and the javascript console gives a 401 error for file: http://allurelle.nl/wp-admin/admin-ajax.php. 401 means that users are not authorised to use this file. One possible cause is that your wp-admin directory is protected in the .htaccess file. You can make an exception to the protection for the problem file with this rule in .htaccess.

    <Files admin-ajax.php>
    Order allow,deny
    Allow from all
    Satisfy any

    .htaccess is a hidden text file in the root of your WordPress install. Take a backup of the file before editing it. An error editing it could blank your entire site, in which case just restore the original.

  3. Allurelle
    Posted 1 year ago #

    Hi, it worked! Great thank you.

    Now i have a question regarding the HTCaccess. When does it change back to normal?
    I can change everything inside the backend and the htcaccess doesn't change right?

    Thanks again!

  4. lorro
    Posted 1 year ago #

    I don't think there is such a thing as a normal .htaccess. If you've added that bit and everything works, you're done.

    When the administrator changes or resets the premalinks, WordPress will rewrite its part of .htaccess to suit, and that will happen automatically.

  5. Allurelle
    Posted 1 year ago #

    Hmm i have a problem. I don't know why, but the htcaccess changes back to normal for some reason i do not know.

    How do i make sure the htcaccess stays the way i say it should be??

  6. lorro
    Posted 1 year ago #

    Is your site working? It seems to be OK now.

    When you say .htaccess changes back to normal, do you mean that the snippet about admin-ajax.php is being deleted?

    Check the file permissions on .htaccess. I think they should be 644.

    WordPress does change .htaccess if you change or save permalinks. But WordPress should only change the lines inside the # BEGIN WordPress / # END WordPress delimiters. The admin-ajax.php snippet should come after the # END WordPress line.

  7. CrouchingWayne
    Posted 1 year ago #

    I'm having the same problem and changing the HTACCESS file hasn't helped:

    Any suggestions?

  8. CrouchingWayne
    Posted 1 year ago #

    Partially resolved, my URL was not the same for site & wordpress on settings -> general tab.

    Now can't log into admin panel...

  9. lorro
    Posted 1 year ago #

    @CrouchingWayne I can get to your admin panel. Can you? What happens when you put your credentials in?

    Your theme has been updated to 1.3.0. You have version 1.2.17.

  10. MrThunder
    Posted 1 year ago #

    I am having the same the issue I have tried everything, I have even installed a clean version of wordpress and woocommerce and only have the realex payments plugin activated to see if it would work.

    I get no JS errors on the checkout page.

    I have added the htaccess code above and made sure the site and wp URLS are the same.

    I am at my wits end, any help would be fantastic

  11. gtvracer
    Posted 7 months ago #

    After trying out all solutions like checking for errors on console (none found), expanding WP memory to 96M, editing .htaccess to allow access to admin.php, making sure site and home URLs are the same in WP settings, I found out why my checkout spinner kept spinning.

    Go to your WP's post database and check for conflicting Checkout post/pages. I had another from a different ecommerce package and that was hosing woocommerce. Cleaned out the database and the spinner is now gone.

    Hope that helps someone else...

  12. crossmedia
    Posted 7 months ago #

    I had same problem and couldnt find the problem neither in console, nor in woocommerce system status. But I have a lot of plugins and I disabled one ny one until checkout worked again.

    I my case the "Captain Admin pligin" was causing the conflict.

    SOLVED ny disabling

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce - excelling eCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.