Support » Plugin: Accept Stripe Payments » Endless loading

  • Resolved wireofhope

    (@wireofhope)


    Hi there!

    I was having issues with this plugin on my main website so I created a staging environment to run all the tests I wanted. I deactivated all of my plugins but Stripe Payments, picked the default theme, updated WordPress and PHP, and unfortunately the plugin still doesn’t work.

    When I click the checkout button, everything works fine, but as soon as I click to pay, then I get a loading logo on the pop-up and nothing happens. It keeps looping without processing the payment or displaying an error message.

    I tried everything and I’m at loss right now. I’m sure there must be something I’m doing wrong, but what? Every help would be appreciated. Thanks so much!

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support mbrsolution

    (@mbrsolution)

    Hi,

    Below you can see the error messages from the URL above. I used Developer Tools in Google Chrome. Maybe this might help you troubleshoot your issue.

    Failed to set referrer policy: The value ” is not one of ‘no-referrer’, ‘no-referrer-when-downgrade’, ‘origin’, ‘origin-when-cross-origin’, ‘same-origin’, ‘strict-origin’, ‘strict-origin-when-cross-origin’, or ‘unsafe-url’. The referrer policy has been left unchanged.
    jquery-migrate.min.js?ver=3.3.2:2 JQMIGRATE: Migrate is installed, version 3.3.2
    jquery.min.js?ver=3.5.1:2 Allow attribute will take precedence over ‘allowpaymentrequest’.
    xe @ jquery.min.js?ver=3.5.1:2
    Failed to set referrer policy: The value ” is not one of ‘no-referrer’, ‘no-referrer-when-downgrade’, ‘origin’, ‘origin-when-cross-origin’, ‘same-origin’, ‘strict-origin’, ‘strict-origin-when-cross-origin’, or ‘unsafe-url’. The referrer policy has been left unchanged.
    pp-handler.min.js?ver=2.0.41:2 reCaptcha: init
    asp-recaptcha-ng.js?ver=2.0.41:87 reCaptcha onload

    Thank you

    • This reply was modified 1 month, 1 week ago by mbrsolution.
    Plugin Author mra13

    (@mra13)

    If this was related to the 3D secure feature then this has been resolved. Please update to version 2.0.42.

    Thread Starter wireofhope

    (@wireofhope)

    Thank you both for your answers!

    @mbrsolution I’m afraid you’re speaking Chinese to me right now! I have no idea what this means at all… Would that be an issue in the settings of the plugin?

    @mra13 Thanks so much, unfortunately I updated the plugin to version 2.0.42 and I still have the same problem. When I try to proceed with the payment, I still have the infinite loading loop and nothing happens.

    Any help would be so appreciated, I really wanted to explore this plugin and its options but I’m totally stuck right now.

    Plugin Author mra13

    (@mra13)

    There is an error happening on this site but I am not 100% sure where it is coming from. Please enable the debug logging option then do a test. That log file might contain some info that gives us a clue:
    https://s-plugins.com/using-the-debug-log-to-solve-issues-on-a-site/

    Thread Starter wireofhope

    (@wireofhope)

    Thank you @mra13 !

    I just enabled the debug logging option and did two tests, but the log file came back empty! It doesn’t look like a payment failure but more like nothing’s happening for some reason…?

    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    Hi.

    I can see your have reCaptcha enabled. Can you disable it and try to make a test payment again?

    I just enabled the debug logging option and did two tests, but the log file came back empty

    Try to click “Clear Log” and see if it’s successful.

    Thread Starter wireofhope

    (@wireofhope)

    @alexanderfoxc Yahooooooo!!!!!! It worked!

    Please see the log below. What was wrong with the reCAPTCHA?? Should it stay disabled?

    [01/17/2021 5:42:31 PM] – Stripe Payments debug log reset

    [01/17/2021 5:43:21 PM] – Payment processing started.
    [01/17/2021 5:43:21 PM] – Got product ID: 13333
    [01/17/2021 5:43:21 PM] – Firing asp_ng_process_ipn_product_item_override filter.
    [01/17/2021 5:43:21 PM] – Firing asp_ng_process_ipn_payment_data_item_override filter.
    [01/17/2021 5:43:22 PM] – The transaction ID of this notification is: ch_1IAfHYEpKyLIryJRQxYjRVCy
    [01/17/2021 5:43:22 PM] – Constructing checkout result and order data.
    [01/17/2021 5:43:22 PM] – Firing asp_ng_payment_completed filter.
    [01/17/2021 5:43:22 PM] – Firing asp_ng_payment_completed_update_pi filter.
    [01/17/2021 5:43:22 PM] – Firing asp_stripe_payment_completed action.
    [01/17/2021 5:43:22 PM] – Notification email sent to seller: contact@wireofhope.com, from email address used: Wire of Hope <contact@wireofhope.com>
    [01/17/2021 5:43:22 PM] – Payment has been processed successfully.
    [01/17/2021 5:43:22 PM] – Redirecting to results page “https://wireofhope.com/test/thank-you-for-your-donation-to-wire-of-hope/&#8221;

    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    I guess you put wrong keys for reCaptcha. Looks like you checked “Invisible” reCaptcha option, but placed regular keys instead. Try to re-enable reCaptcha, then uncheck “Invisible” option and try again, I suspect it should be working as well.

    Thread Starter wireofhope

    (@wireofhope)

    Thanks so much for your help @alexanderfoxc ! That’s all it was 😛 I re-entered the reCAPTCHA keys again and it’s working great. Thanks so much!

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.