WordPress.org

Support

Support » How-To and Troubleshooting » Encoding problem when posts sharing on facebook (after update to 3.0)

Encoding problem when posts sharing on facebook (after update to 3.0)

  • Hello there,
    In all of my blogs i have updated to version 3.0 “thelonious”, have problem when i try to share a post on facebook (via facebook connect / addthis plugin even with a simple url copy-paste). All the characters are in the greek language (encoding UTF-8) have encoding problems!

    Any Suggestions?
    Thank you.

Viewing 10 replies - 1 through 10 (of 10 total)
  • anyone? plz guys…

    ktsixit
    Member

    @ktsixit

    I have the same problem. I am using greek characters and utf-8 encoding too.

    mienque
    Member

    @mienque

    I also have the same issue. I have tried hours to hours to fix it but not successed.

    mikkohei13
    Member

    @mikkohei13

    Had similar problem. Converting all my template files to UTF-8 without BOM (with Notepad++) solved this.

    bouropoulos
    Member

    @bouropoulos

    I have the same problem with my posts. I tried converting my theme’s template files with Notepad++, as mikkohei13 suggested, but nothing happened. Should I convert the default theme templates as well?

    This is a very annoying problem and I am not sure if it is a WordPress or a Facebook problem… please help!

    Same problem with Hungarian characters.

    Joe
    Member

    @shopping-guide

    Notepad++ is a great text editor, especially for developers working with code. Get it here:

    http://notepad-plus-plus.org/download

    In your WordPress installation files, browse to your themes folder:

    example.com/blog/wp-content/themes/mycustomtheme/

    Inside this folder, open all your files ending with *.php using the Notepad++ program. In the menu bar at the top, look for:

    Encoding > Convert to UTF-8 without BOM

    Save the file. Repeat with all .php files. Upload all your edited files back to the server via ftp if you downloaded them locally first.

    bouropoulos
    Member

    @bouropoulos

    Thanks Joe!!!

    I was desperate, I’ve did it once more after your comment and IT WORKED!!!

    Thanks again…

    Joe
    Member

    @shopping-guide

    Credit goes to mikkohei13 for the solution, I just spelled out the steps. 🙂

    Joe

    The solution is not working, I converted all my template phps, the problem still exists.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Encoding problem when posts sharing on facebook (after update to 3.0)’ is closed to new replies.