WordPress.org

Support

Support » How-To and Troubleshooting » Enclosure tag fields in 1.5 not getting populated

Enclosure tag fields in 1.5 not getting populated

  • I’ve been using WordPress 1.5 on several sites now and it’s working great. But I have a problem with the enclosure tags for podcasts.

    I am able to get the enclosure tag into the post and it does show up in the RSS feed — BUT the length=”” and type=”” fields are not getting populated.

    I thought I was up and running fine until I got two techs (one from Podcast Alley and one from iPodder) who both brought the same error to my attention:

    Your Current Enclosure tag is missing info:
    <enclosure url=”http://rpm.cachefly.net/eers/Robert-Kiyosaki_02-22k.MP3″ length=”” type=””/>

    You should Populate these fields as follows:
    length=”” >> should be length=”123456″ where the numbers are the size in bytes of your podcast type=”” >> should be type”audio/mpeg”

    I also verified my feed at: http://audio.weblogs.com/feedDebug.html

    And it confirms that htere is an error. This is what was reported:

    Feed debugger result
    Error: enclosure length must be greater than zero.

    I tried to go in and manually enter those missing elements in the enclosure through the custom fields section of the advanced admin area of WP, but this is what I got:

    <enclosure url=”url=”http://rpm.cachefly.net/eers/Robert-Kiyosaki_02-22k.MP3″ length=”6268865″ type=”audio/mpeg”” length=”” type=””/>

    It still produced an error when I tested it.

    Please — can someone help. I know I need to get my enclosure to look like this: url=”http://rpm.cachefly.net/eers/Robert-Kiyosaki_02-22k.MP3″ length=”6268865″ type=”audio/mpeg”

    … but I’m not having any luck. What am I doing wrong? I couldn’t find anyone else in the forums or in a Google search having this problem, so hopefully a WP expert can help provide some insight.

    The blog URL is: http://www.businessownerscoachingclub.com/businessownersblog

    and the RSS feed is:
    http://www.businessownerscoachingclub.com/businessownersblog/wp-rss2.php

Viewing 6 replies - 1 through 6 (of 6 total)
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Enclosure tag fields in 1.5 not getting populated’ is closed to new replies.
Skip to toolbar