Support » Fixing WordPress » Enabling Sending Referrers.

  • Wow, this makes me mad. I just tried in 3 web browsers with the instructions given on the codex page. We need to find an alternative to sending referrers, this is obviously bullshit.

Viewing 15 replies - 1 through 15 (of 85 total)
  • I second this, it should be an option we can turn off if we like by being leet and modifying a config file ourselves. Both of my browsers are set to send referrers and regardless of what I do it flipflops on deciding to work or not work. Very, very lame. ;( I can’t even switch themes to test out my new design.

    webwiz

    (@webwiz)

    Well, I just had the same problem. But, by guesswork, checked my firewall settings and managed to fix it.

    For what it’s worth, I have Zone Alarm Pro installed. Checking the Privacy options, I looked at the site list. The “private header” column caught my eye, so I right-clicked that column against the WP site entry.

    From the context menu that pops up, I chose “Options”. On the first tab, “Cookies”, I noticed a check mark against the entry for 3rd party cookies: “Remove private header information”.

    Unchecking this entry and pressing “Ok” fixed the problem. I can now edit links from both Opera and Firefox.

    Hope this helps (Zone Alarm users, anyway.)

    Regards. David.

    Thank you David – I’ve posted your information into Codex (It was better than what I had written there 🙂 )

    rustindy

    (@rustindy)

    It’s *extremely* unlikely that some sites requiring headers work while WP doesn’t, unless a firewall or router (or privacy setting in the browser) is blocking the header transmission on a per-domain basis.

    To see if headers are making it to your domain at all, create a file named info.php containing the following lines:
    <a href="info.php">click me</a>
    <?php
    phpinfo();
    ?>

    Upload the file and open it in a browser. Click the link at the top. When the page refreshes, scroll down to the <b>HTTP Headers Information</b> section (about 1/3 of the way down). The field called “Referer” should contain your domain name and the full path to the “info.php” file you just created (like “http://www.mydomain.com/info.php&#8221; or similar).

    If it does, then referrers are not being blocked, and it is a bug. If the field is empty or contains anything but the exact path to your “info.php” file, then it is something else – most likely a router/firewall or privacy setting.

    The important thing is to *click the link first* before checking the referrer setting – it’ll be blank (or non-existant) since you will have typed the address in manually. So click first, check after 😉

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Please, contribute to this if you’d like:
    http://codex.wordpress.org/Enable_Sending_Referrers

    amiantos

    (@amiantos)

    Hopefully this’ll be enough proof for everyone then that this isn’t a silly end user problem:

    http://ihavebeenfloated.org/info.php

    As can be seen there, referrers can easily be seen by my server. Unfortunately, for me, WP still is giving me the same error. I will paste the error text here as “proof” that I am still actually getting the error, even though I could probably type it from memory at this point: “Sorry, you need to enable sending referrers, for this feature to work.”

    Thank you RustIndy for providing me with a better way to test my theory that this is a problem with WordPress and *not* myself. If required, I will even take a screenshot with my info.php right next to my WP install giving me an error.

    So much for it being a “server configuration error” or “a problem with your firewall” ad nauseum. (Would it be too much for me to have a smug smirk on my face at this point? *looks around the room* No? OK, then I will go ahead.)

    Thanks for your info, RustIndy !
    Run the info.php and i have this two references to the referer:
    In ‘Session’:
    session.referer_check : no value

    In ‘Environment’:
    HTTP_REFERER: http://www.cromosfera.com/info.php

    Thanks and saludos.

    rustindy

    (@rustindy)

    Jose, were you having this problem as well?

    amiantos

    (@amiantos)

    Jose mentioned he was having the same problem here:

    http://wordpress.org/support/topic.php?id=20408

    Yes, i have the famous problem “Sorry, you need to enable sending referrers, for this feature to work.” when i try to activate a plugin, delete a link, delete a user, delete a category, etc…
    thanks,

    rustindy

    (@rustindy)

    Well, if either of you wants to email me your password and step-by-step instructions on how to trigger the problem, I’ll be happy to do the double-check for you.

    russ@innereyesTAKETHISOUT.com

    amiantos

    (@amiantos)

    I’m not sure if that’s the most secure idea, so I’ll pass on that unless a developer contacts me specifically.

    As it is, as I stated in another thread, I had a good friend of mine (of five years) who lives across the United States from me try, and he encountered the same problem. Also, I tried on multiple computers at my work (various vanilla installs of Win2k, Win98, WinXP with IE) and had the same problem each time.

    Perhaps if I made a new user account for you, but I would assume that is possibly blocked by the security as well so I wont even bother, I think.

    rustindy

    (@rustindy)

    Ah k, didn’t know that had already been done.

    What versions of MySQL and WordPress are you using?

    amiantos

    (@amiantos)

    MySQL: 4.0.20

    WP: 1.5-beta-1 2005-01-06

    I was going in maybe install the 2005-01-10 nightly and see if that fixes it but I really doubt it will, though I may at this point anyway.

    BTW: Unlike someone’s problem above that only activated upon installing a newer build, my problem occured out of thin air, for no obvious reason, no apparent cause attached. One minute it was working just fine, next minute it just suddenly decided to stop working and hasn’t worked sense. Strangest thing ever, makes no sense to me.

    (Also, why in the hell have no stores in my area gotten The Minish Cap in yet? Damnit.)

    NuclearMoose

    (@nuclearmoose)

Viewing 15 replies - 1 through 15 (of 85 total)
  • The topic ‘Enabling Sending Referrers.’ is closed to new replies.