Support » How-To and Troubleshooting » [Resolved] Enabling RSS/ATOM

[Resolved] Enabling RSS/ATOM

  • Can anyone tell me how to enable the RSS, both for posts and comments? Seems like majority of WP users are having the same issue, since I checked quite a few of them have the same problem. When you click on the RSS links “Entries (RSS) and Comments (RSS)”, on the bottom of the WP enabled site it returns a dead page.

    Also, does WP support ATOM? And… clean URL’s perhaps?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Moderator James Huff


    There is, as far as I know, no way to combine the comments and posts feeds (which is why they are provided as separate feeds).

    As for the “dead” links at “Entries (RSS) and Comments (RSS)”, they aren’t dead. They are very much alive. Your browser is displaying an error simply because it does not understand the feed: placed in front of the http:// . feed: is a new protocol which, once fully implemented, will launch your default RSS reader and either subscribe you to the feed, or check for recent updates. To see your live RSS feed, remove the feed: from the URL, or permanently remove the feed: from the templates which house your RSS links.

    As for Atom support, you can either find your atom feed at domain.com/wp_file_directory/wp-atom.php or domain.com/wp_file_directory/feed/atom/ if you have permalinks enabled.

    yes, remove the “feed”!

    macmanx: “As for the “dead” links at “Entries (RSS) and Comments (RSS)”, they aren’t dead. They are very much alive. Your browser is displaying an error simply because it does not understand the feed:”

    That is not correct. Here is the result when you open my “RSS” link from my sidebar.

    <!-- generator="wordpress/1.5" -->
    <rss version="2.0">
    <title>Cranial Cavity</title>
    <description>Cobwebs, Dust, and a Few Living Cells</description>
    <pubDate>Sun, 17 Apr 2005 01:51:25 +0000</pubDate>
    <title>Grandstanding For Me, and None For Thee</title>
    <pubDate>Sun, 17 Apr 2005 09:44:44 +0000</pubDate>
    <category>International Politics</category>

    That is only a small section of the entire result.

    My guess is xaero has the wrong url in their sidebar links. Call up the correct url by looking at the source of your index page via your browser.

    And BTW it works with the RSS feed plus comments as well.

    By default, the RSS 2.0, I think, feed is set up in the sidebar of the default installation of WordPress, right? Should links be added to set the Atom and other feeds or will any feed reader just “find” them from the links to them in the header? If the feed reader finds them, is the link in the sidebar just a courtesy link for the site and the comments? Or do they serve a purpose.

    We really need more explanations about this in the Codex. I’m still trying to research and learn more about how these all work myself.

    Moderator James Huff


    Marc, thank you for either not reading my entire reply, or not taking a moment’s pause to make an attempt at comprehension. That’s my favorite attribute of these forums. Your feed URL obviously doesn’t have feed: in front of it. Go find a site that does (IOW, a new WordPress install), you’ll see what I’m talking about.

    Lorelle, an RSS reader should be able to dig through the site for the proper feed. For example, if your RSS reader is set to use Atom feeds only, your feed reader should be able to find the Atom feed by entering only your blog’s URL in whatever subscription field your RSS reader has.

    You’re saying to just remove the “feed” word from those links on the bottom of the site… But how?

    Moderator James Huff


    In the Footer Template (footer.php), change:

    <a href="feed:<?php bloginfo('rss2_url'); ?>">Entries (RSS)</a>


    <a href="<?php bloginfo('rss2_url'); ?>">Entries (RSS)</a>

    and change:

    <a href="feed:<?php bloginfo('comments_rss2_url'); ?>">Comments (RSS)</a>


    <a href="<?php bloginfo('comments_rss2_url'); ?>">Comments (RSS)</a>

    As are smart ass answers.

    But back to innomind’s question, which in part read “When you click on the RSS links “Entries (RSS) and Comments (RSS)”, on the bottom of the WP enabled site it returns a dead page.”

    That has nothing to do with how an RSS reader or Technorati/Google read them. (via auto discovery)

    Those links are provided for what? To enable visitors to copy the URL to be entered in the RSS reader manually.

    As such being “dead” is an indication the wrong URL is entered and a visitor must dig thru the sites source code to get the correct one.

    Thanks everyone, I really appreciate it. It worked, and the site is live now.

    Moderator James Huff


    innomind, congrats on getting every running.

    Marc, a feed link without feed: in front of it will normally load in any browser, but a feed link with feed: in front of it will not load and produce an error in most browsers. Personally, I consider that a dead link.

    Additionally, I have no clue what you hoped to accomplish by telling another member that his feed link wasn’t dead because your feed works.

    Since we’re talking about feeds I’ve looked through the codex but I’ve not found anything about how to change the title for a feed for a particular category (so instead of having 4 feeds that have the exact same description, I’d like to specify the actual particular category for a specific feed). Any ideas?

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] Enabling RSS/ATOM’ is closed to new replies.
Skip to toolbar