Support » Plugin: W3 Total Cache » Enabling memcache for database cache doesn’t appear to work

  • Resolved s0medude

    (@s0medude)


    Hi, I’ve been using W3TC on an older wordpress site for some time now mostly for managing page cache on disk & purging varnish when posts are update. Recently have been looking to reduce DB load by enabling the database cache and pointing it to a memcache instance and have been having issues. Everything looks OK, but when I load pages in wordpress I don’t see any connections initiated to the memcache instance unless I specifically load the W3TC plugin page under /wp-admin/ – I also see connections initiated to the memcache instance if I tell the plugin to flush the memcache cache, so it appears to know about the memcache instance & how to connect to it, but it does not appear to be using it in normal, non-admin operation. Thoughts?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @s0medude

    Thank you for the inquiry and I am happy to assist you with this.
    Can you please temporarily enable the database Cache debug in Performance>General settings>Debug, thick the Database cache box and save all settings and purge the cache. And please share your URL so we can check this.
    Thank you!

    Thread Starter s0medude

    (@s0medude)

    Hi @vmarko, Thanks for your reply & I hope you are well. I do have debug enabled for the Database cache, but I was not able to find any debugging output in the php error log. Unfortunately, the URL is inaccessible as it’s behind a firewall but maybe you can point me in the right direction.

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @s0medude

    The Database Debug does not output in the error log.
    Visit your website and Inspect it and you should see a HTML snippet something like:

    <!--
    Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

    Can you please share that snippet?
    Thank you!

    Thread Starter s0medude

    (@s0medude)

    Oddly, I’m not seeing that snippet either

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @s0medude

    Thank you for the information. In some cases, some minify settings, possibly Cloudflare or something else might be removing W3TC comment.
    If you inspect your page while in the wp-admin area, can you see the snippet in the bottom of the HTML? And if so, can you please share it (remove the website URL)
    Thank you!

    Thread Starter s0medude

    (@s0medude)

    I don’t see anything in HTML on wp-admin either, but I believe W3TC is configured to ignore wp-admin pages. I do see the plugin enabled & configured in wp-admin and can provide some data from that if helpful.

    The plugin is currently enabled in community mode.
    Page cache: enabled - using Disk: Enhanced
    Minify: disabled
    Database cache: enabled - using memcached
    Object cache: enabled - using memcached
    Browser Cache: enabled
    CDN: enabled - Amazon Cloudfront
    Enable varnish cache purging: enabled - 2 varnish IP addresses
    Cloudflare - disabled
    New relic - disabled
    Enable Google Page Speed dashboard widget - enabled
    Use single network configuration file for all sites - enabled
    Hide performance settings - enabled
    Verify rewrite rules - enabled

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @s0medude

    Thank you for the information. It seems that something is removing the HTML comment.
    If you are seeing connections initiated to the Memcache instance when the plugin flushes the Memcache, that means that the DB cache Memcached is working just fine.
    If you want you can drop us a note via the plugin in Performance>Support and provide us with the URL or via our website https://www.w3-edge.com/contact/
    Thank you!

    Thread Starter s0medude

    (@s0medude)

    If you are seeing connections initiated to the Memcache instance when the plugin flushes the Memcache, that means that the DB cache Memcached is working just fine.

    Even if I am not seeing any connections to Memcached during normal operation?

    If you want you can drop us a note via the plugin in Performance>Support and provide us with the URL or via our website https://www.w3-edge.com/contact/

    I can submit contact via the website, but I still cannot provide the URL as it is inaccessible from the public internet.

    • This reply was modified 2 years, 10 months ago by s0medude.
    Thread Starter s0medude

    (@s0medude)

    Just to close the loop on this, I believe this was a result of W3TC being unable to write files to WPROOT when enabling this. It seems to copy these files from WPROOT/plugins/w3-total-cache/wp-content: db.php & object-cache.php & advanced-cache.php

    The issue was my WP environment does not allow the web server to write files into WPROOT. Once I copied the 3 files manually, I began to see connections to the memcached server during page refreshes.

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @s0medude

    Thank you for the information!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Enabling memcache for database cache doesn’t appear to work’ is closed to new replies.