Support » Plugin: Disable Gutenberg » Enabling “Disable Gutenberg” disables the abality to edit post or page button fr

  • Resolved shemzone

    (@shemzone)


    Hi Jeff and first of all, thank you for your very useful plugin.
    I noticed that when your plugin is enabled, it disabled the abality to edit a post (or a page) from the front end view (as connected user having editing role).
    Actually, the editing button is not displayed.
    Dis I missed someting in the settings?

    Thank you

    Rgds
    Fred

Viewing 15 replies - 1 through 15 (of 18 total)
  • Hi,

    I can confirm this issue although the edit button is still displayed, but the edit link: https://www.asdf.com/wp-admin/post.php?post=69&action=edit is shortened to https://www.asdf.com/

    So I disable “Disable Gutenberg” 😐

    Thanks in advance,
    Chris

    I have the same issue with the customizr-pro theme. The edit button is broken and there are error messages on top of the page and each post.
    After disabling the plugin the errors are gone.

    The line responsible for this bug is:

    add_filter('get_edit_post_link', 'disable_gutenberg_get_edit_post_link');

    Plugin Author Jeff Starr

    (@specialk)

    Will investigate today, thanks for reporting. It would be helpful also to know the following:

    – The version of WordPress
    – The version of Gutenberg plugin (if WP is less than 5.0)

    Thanks!

    – WordPress version 4.9.8 (french on my side)
    – Disable Gutenberg 1.3

    Plugin Author Jeff Starr

    (@specialk)

    @shemzone, thanks I understand that this is for Disable Gutenberg 1.3. What I need to know is which version of Gutenberg plugin you are using. Thanks!

    Plugin Author Jeff Starr

    (@specialk)

    Can anyone try switching to the default WP theme and seeing if the PHP warnings remain? I am not able to see any warnings on WP 4.9.8 running the latest Gutenberg and default theme. Need to be able to recreate the issue in order to fix it.

    @specialk

    I’ve got a local install with theme Twenty Sixteen and the only plugin active is Disable Gutenberg version 1.3.

    With this setup the “Edit Post” link is missing from the black WP Admin Bar across the top of the screen.

    Deactivating “Disable Gutenberg”, restores the “Edit Post” link.

    I’m getting this warning in my error logs.

    > Warning: call_user_func_array() expects parameter 1 to be a valid callback, function ‘disable_gutenberg_get_edit_post_link’ not found or invalid function name in /app/public/wp-includes/class-wp-hook.php on line 288

    Plugin Author Jeff Starr

    (@specialk)

    @salcode

    Thanks, I am still not seeing any error. Which options are you enabled in the plugin settings?

    Also, you are using WP 4.9.8 and the latest version of Gutenberg, correct?

    • This reply was modified 1 year, 1 month ago by Jeff Starr.

    @specialk

    – Complete Disable
    – Disable Nag

    are the only two checked options.

    I tried using “Restore default plugin options” and I’m still getting the same behavior.

    FYI, I’m running PHP version: 7.0.3

    Sorry @jeff for my misunderstanding 😊
    In fact, I don’t use Gutenberg plugin at all on my websites.
    I installed your plugin to avoid my users to be tempted to installe it or having the ad message of Gutenberg realese for the next WP version.

    F.

    Plugin Author Jeff Starr

    (@specialk)

    No problem, that information is just as useful. Thank you @shemzone!

    Plugin Author Jeff Starr

    (@specialk)

    @salcode

    Still not seeing any issue using the exact same setup. Maybe it is related to some other plugin.. are you able to troubleshoot your plugins (and theme)?

    Just want to get this fixed!

    Plugin Author Jeff Starr

    (@specialk)

    Here is a beta version of DG 1.3.1: Download from Plugin Planet. Please give it a try and let me know if it resolves the issue. Thank you.

    @specialk

    Disable Gutenberg v1.3.1 from your download link seems to have corrected the problem.

    Recreating the Problem (using Disable Gutenberg v1.3.0)

    I’m using Local by Flywheel and below are my steps to recreate the problem on a fresh install.

    Create Local by Flywheel new install
    disablegutenberg.test
    Preferred Setup (PHP 7.1.7, nginx + Varnish, MySQL 5.6)
    Not multisite

    Log into website (http://disablegutenberg.test/), which is running WordPress 4.9.8

    Visit http://disablegutenberg.test/hello-world/, the WP Admin Bar is displaying properly (with the “Edit Post” link)

    Add new plugin via web interface (http://disablegutenberg.test/wp-admin/plugin-install.php) (version 1.3)
    Install and activate “Disable Gutenberg”

    Return to http://disablegutenberg.test/hello-world/, the WP Admin Bar is missing the “Edit Post” link and this
    warning appears in the content.

    (as noted above Disable Gutenberg v1.3.1 has corrected this issue)

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Enabling “Disable Gutenberg” disables the abality to edit post or page button fr’ is closed to new replies.