Support » Fixing WordPress » enabling comments on separate blog on a ordpress website

  • Using Twenty Ten as my theme I created a website – Seeinfohere.com and after upgrading to WP 3.4.2 have added a separate blog to it. However I can’t enable comments on that blog and whatever I try it still says”Comments Off”. Is there a way to solve this without having to change the code?
    I did look at the theme’s code (Admin – appearance – editor) but can’t see the comments template code and in any case am nervous about changing it in case I make matters worse.
    Grateful for any advice.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Krishna

    (@1nexus)

    Member

    Did you set your comment options at Dashboard > Settings > Discussion ? If not go there, check the boxes of your liking and save the changes.

    Hi Krishna,
    Yes, I’ve tried that route, in fact I think I’ve tried everything except changing the Twenty Ten code in Appearance -Editor.
    I’ve found the appropriate ode in other fora – can anyone tell me where I should insert it?

    Krishna

    (@1nexus)

    Member

    You do not have to change any code. You only need to check/un-check the appropriate check boxes in your discussion settings.

    Also, make sure that you do not edit the Twenty Ten theme. Create a Child Theme, if you want to edit/ customize the default theme.

    Sorry Krishna but neither checking nor unchecking in Settings – Descussion works for me but thanks for the headsup re creating a child theme.

    In an attempt to allow comments on the separate blog page of Seeinfohere.com I have visited Dashboard-Settings-Discussion and checked the following:
    allow notification from other blogs;
    allow people to post comments;
    comment author must fill out name and email;
    enable threaded comments 3 deep;
    anyone can post a comment;
    show avatars;
    G suitable for all audiences.
    I then clicked save Changes and went to the top of the page where it said “Settings saved”
    However, over at the website my separate Blog page still says “Comments off”
    Am I missing something?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘enabling comments on separate blog on a ordpress website’ is closed to new replies.