Support » Plugin: Plugin Organizer » Enabling by Page not working

  • Resolved petrich


    Hello Everyone

    First many thanks to Jeff for this simple but very efficient plugin. Nice job !

    Then, here is the behaviour I am facing:

    I am running WP 3.5.1 on a W2K Server 2008 R2 Std (Web server IIS 7.5)
    PHP 5.4.12
    I am running Plugin Organizer v 2.5.9

    The only thing which is not working is the enabling plugin on pages. Each time I click on a plugin – which was previously disabled for the whole site – to enable it on a specific page, then I update the page and nothing has been saved.

    I tried to activate WP_DEBUG to ‘true’ and here is the result I got (which won’t be of any help I guess)

    Notice: get_current_theme is deprecated since version 3.4! Use wp_get_theme() instead. in E:\inetpub\wwwroot\worldtour\wp-includes\functions.php on line 2839

    Warning: is_readable(): open_basedir restriction in effect. File(C:\inetpub\wwwroot\worldtour/wp-content/themes/twentytwelve/ is not within the allowed path(s): (E:\inetpub;C:\Program Files\MySQL\MySQL Server 5.5\bin) in E:\inetpub\wwwroot\worldtour\wp-includes\l10n.php on line 339

    Notice: add_option was called with an argument that is deprecated since version 2.3 with no alternative available. in E:\inetpub\wwwroot\worldtour\wp-includes\functions.php on line 2925

    So where do you think I should investigate to make this working as it should be.

    Thank you guys !

Viewing 5 replies - 1 through 5 (of 5 total)
  • I forgot to add that I already moved PluginOrganizerMU.class.php to mu-plugins directory

    But I think I am getting something wrong in log that I have activated./

    Here is the message I got at the exact moment I tried to activate Contact Form 7 plugin for a specific page:

    [19-Apr-2013 14:11:37 UTC] Erreur de la base de données WordPress Field ‘disabled_plugins’ doesn’t have a default value pour la requête
    INSERT INTO wtrlm2013_PO_post_plugins (enabled_plugins,permalink,post_id) VALUES (‘a:1:{i:0;s:36:\”contact-form-7/wp-contact-form-7.php\”;}’,’’,108) faite par edit_post, wp_update_post, wp_insert_post, do_action(‘save_post’), call_user_func_array, PluginOrganizer->save_enable_plugin_box, W3_Db->insert, W3_DbCache->insert, W3_DbCallUnderlying->insert, W3_Db->insert, W3_DbProcessor->insert, W3_Db->default_insert, W3_Db->query, W3_DbProcessor->query, W3_Db->default_query

    it seems that the query :

    INSERT INTO wtrlm2013_PO_post_plugins (enabled_plugins,permalink,post_id) VALUES (‘a:1:{i:0;s:36:\”contact-form-7/wp-contact-form-7.php\”;}’,’’,108)

    … is trying to insert 3 values in a table xxx_PO_post_plugins, which is made of 4 columns.
    That’s the reason of the generated error.

    I didn’t figure out how the queries are generated during the enabling / disabling process in your plugin Jeff, but I have the sensation it’s not hard coded anywhere but dynamically generated.

    Can you confirm ?
    Do you think it can be due to MySQL for Win. being be less permissive than on Apache environment ?

    I will probably stop investigating for now.

    Let me know what you think when you get a moment to troubleshoot that.




    i am also experiencing a similar problem except everything used to work ok (selective loading worked fine) but now it doesn’t work. I have global disabled for some plugins set and selective loading doesn’t seem to work anymore. How can i troubleshoot this?

    thank you for your help!

    Plugin Author Jeff Sterup


    I wasn’t specifying one of the fields in the insert and it no longer has a default value. I just released version 2.6. Try that and see if it solves your problem.

    Yep Much better 😉

    Thanks a lot !

    Nice job…

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Enabling by Page not working’ is closed to new replies.