Support » How-To and Troubleshooting » Enable sending referrers

Enable sending referrers

  • Sorry, you need to enable sending referrers, for this feature to work.
    Huh? I get this when trying to delete a post. I know it’s something with my firewall(s), but why should sending headers be required?? It seems kinda strange to absolutely require that when a lot of people are going to be denied access for that reason.
    Is there any way around this? Because if there isn’t, I either have to configure a software firewall and two hardware firewalls to permit WordPress to work, or just switch to something else!

Viewing 15 replies - 1 through 15 (of 38 total)
  • The hardware firewall shouldn’t be stopping it (unless it’s an advanced one that does packet filtering).

    I have tried in 4 different machines and just keep telling the error, i just get tired of that and edited
    on line 369/370 you have a function
    function check_admin_referer()
    I just changed to
    function check_admin_referer() {
    $adminurl = strtolower(get_settings(‘siteurl’)).’/wp-admin’;
    $referer = strtolower($_SERVER[‘HTTP_REFERER’]);
    if ( !strstr($referer, $adminurl) ) {
    //die(‘Sorry, you need to enable sending referrers, for this feature to work.’);
    $referer = “localhost”;
    and all plugins install ok now, it’s not a pretty solution but it works.

    Any comment jus mail me josesilva at t6m dot com

    I also had this error from the outset – couldn’t delete posts or enable plugins, etc.
    In my software firewall, DISabling [privacy control] fixed the problem.

    Thanks so much josesilva – that worked perfectly! 🙂

    I also had to disable my Privacy Control Manager in my Firewall. What I don’t get is that by clicking edit/delete you are making an http request on port 80 which is already permitted by the firewall. It works for all other Web sites, why not this?

    Bless you josesilva a thousand times over. It works now.

    OMG! Thank you so much! Now everything works fine! 🙂

    I am having the same problem… try to delete a link and I get “Sorry, you need to enable sending referrers, for this feature to work.”
    I tried the editing of function check_admin_referer() but it did not work for me. I am using Firefox as a browser but tried in IE as well, still didn’t work. I am also using Norton Anti Virus so disabled it to see if that was conflicting in anyway, but it still didn’t work (I know an IT Security person who tells me to dump Norton because it is such a pain and is usually the root of all the networking problems she deals with).
    All that said, the problem could still be in my set up: I am running WordPress on my default installation of Apache on my home computer.
    My ISP here in BC Telus, has started to block port 80 to stop people from running web servers from their standard accounts, have to give them a whole lot more $$ to get a static IP and open port 80. However, I set my router (standard Linksys Etherfast cable/dsl 4 port) and configured Apache to listen to port 9090 for the http server. I also use http://www.no-ip.com and their Dynamic Update Client to automatically update the dynamic IP # assigned by Telus.
    It all works fine, and I do this so that I can build and test web sites on my home computer. Now I say it all works fine, or has, at anyrate, until this ‘referer’ problem. I can’t seem to find a fix that works, and that may be simply because of the wacky rerouting going on explained above. Though I am not sure, and I suppose will not be sure until I post all of this up on a server and get the proper URL without having to reroute to different ports etc.
    BUT if anyone has any other thoughts as to what may be going on, I would love to try and work them out as I really want to be able to run WordPress off my seerver at home as well…

    I’m still having this problem, even though I stopped my firewall completely. Could there be any other solution to this?

    I had the same problem where I couldn’t delete any posts (I got the message saying “Sorry, you need to enable sending referrers, for this feature to work.”). What I had to change just now in my firewall was to turn off “information hiding”, which blocks brand of my computer, web browser, and last web site visited. Now it works again, although it’s no longer a dark secret that I use Safari on an eMac to surf my own blog.

    I had exactly this problem a while back. Turned out it wasn’t my firewall, wasn’t my isp, wasn’t my computer. Just internet explorer’s security settings. I changed to FireFox and the problem vanished. After much fiddling around in IE I managed to turn off whatever was causing it (although I have no clue what it was) and now everything works fine.

    what I did is just go to my Norton Internet Security and add my domain and allowing all the privacy setting……….and it is okay.


    i had the same problem too. but after i edited the “admin-functions.php” it worked…
    thank you 🙂

    I had the same problem. In my case it was because I had just installed the latest security upgrade to ZoneAlarm Pro, and it had turned “block private headers” ON for my website. I turned it back on for just that site, and it works fine now.

Viewing 15 replies - 1 through 15 (of 38 total)
  • The topic ‘Enable sending referrers’ is closed to new replies.