WordPress.org

Forums

Gravity Forms Salesforce Add-on
[resolved] "Enable Salesforce integration" Missing (11 posts)

  1. Lsnewton
    Member
    Posted 2 years ago #

    I'm running Gravity Forms 1.7.2 and the Web-to-Lead Add-on v2.2.4.4 (as it's hooking into a Salesforce Group Edition). The form is working fine but I cannot get it to forward leads through to Salesforce.
    The instructions of the Add-on settigns page say to check a box under the 'Advanced' section of the form settings labelled "Enable Salesforce Integration". However I cannot see this box, nor does an 'Advanced' section even appear in the settings.

    Could the settings have been changed in this Gravity Forms release and the plugin just hasn't caught up or something?

    http://wordpress.org/extend/plugins/gravity-forms-salesforce/

  2. upupdowndown
    Member
    Posted 2 years ago #

    I am having the same problem.

    The Gravity Forms plugin revised a bunch of views in the latest update, so this plugin has not caught up yet. I have one enabled and wanted to disable it.

    I think I will try to edit the setting directly in the DB.

  3. MonkeyPress
    Member
    Posted 2 years ago #

    Same problem here. It looks like the latest GF update broken this integration.

  4. Anton Timmermans
    Member
    Posted 2 years ago #

    Hello,

    I had the same problem with the salesforce plugin, the reason it doesn't work anymore is because gravityforms overhauled the settings page.

    If you use a version management system you can use the patch I made:
    Patch for setting

    If you don't you can download the full modified plugin here.

    I hope this helps you and maybe Zack can use this to make a new version for everyone to download.

  5. blakejnolan
    Member
    Posted 2 years ago #

    Thanks for the work on this Anton! Even after installing this fully modified version, I'm getting this error on the main "Salesforce" settings under the "Forms" menu:

    Fatal error: Class 'SoapClient' not found in /home/ampushco/public_html/wp-content/plugins/gravity-forms-salesforce/developerforce/include/SforcePartnerClient.php on line 44

    Anyone else? If I leave that plugin, "Gravity Forms Salesforce API Add-On" activated, I can't see the additional form editor button sidebar (ie. Standard Fields, Advanced FIelds, etc.)

    And idea what going on here? Thanks!

  6. Anton Timmermans
    Member
    Posted 2 years ago #

    SoapClient is a build in php object so it has nothing to do with this plugin.

    btw. I didn't fix Salesforce API Add-On because I can't test it. I only fixes Salesforce Web To Lead plugin.

  7. blakejnolan
    Member
    Posted 2 years ago #

    Got ya. Thanks Anton.

    One more quick question... Where do the Leads end up in SalesForce. I did a test submission, and I can't seem to find the new Lead/contact.

    I'm not too familiar with Sales Force (working on a clients page). Any help here would be greatly appreciated. Thanks!

  8. Anton Timmermans
    Member
    Posted 2 years ago #

    I don't know anything about salesforce itself, I only implement it for clients. You'd have to email salesforce about it.

  9. Lsnewton
    Member
    Posted 2 years ago #

    That version works great, Anton. Thank you so much!

  10. juhasev
    Member
    Posted 2 years ago #

    I have gravity forms 1.7.5 installed with sales force plugin 2.2.4.4. No luck with the Anton's patch, suspecting something else has changed? Has anyone solved this problem with newer version if gravity forms?

    It also seems like there is no way to obtain the older version of gravity forms. All what is offered is the very latest version. Bummer.

  11. Zack Katz
    Member
    Plugin Author

    Posted 2 years ago #

    The Web to Lead functionality checkbox visibility issue is fixed in version 2.2.6.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Gravity Forms Salesforce Add-on
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic