Support » Fixing WordPress » Enable Referrers Possible Solution

  • To those of you who are still experiencing the enable referrers glitch in your WordPress blogs, I am writing about a solution that appears to be working for me thus far.

    By way of background, I received the error “Sorry, you need to enable sending referrers, for this feature to work” intermittently when I try to write a new post. I received the message when I tried to “save,” “save and continue editing” or “publish” a new post, or when I tried to edit an already-published post.

    I received the message when I used IE6 or Firefox. I received the message regardless of the 4 different computers I used to try to write new posts.

    I used the WP support forums, which proved useless. Also, I do not believe that it had anything to do the browser or firewall settings since I operate 2 blogs (one personal, one business) – both are hosted by the same provider, both use WP 2.0.4, and I installed both using the easy way where WP creates the database and the table automatically. For my business blog, I never received the enable referrers error. Therefore, I seriously doubted that any of the proposed solutions and firewall problems were the problem. I continue to believe that, for the most part, these are the things causing most people to get this error.

    However, I read on the support form that “I had the same problem, so I went into the cpanel of my server, then to phpMyAdmin, and brought up the WordPress tables, found and edited the wp-options to include the /wordpress/ folder in the url. That did the trick.” To the person who posted this, it would be more helpful to give more detailed instructions about how to accomplish this. Since WP likes to tout it’s easy install method, most users, including myself, are not familiar with tables and databases. Therefore, a step-by-step guide to accomplishing this could be useful.

    Elsewhere, I read about ensuring that the database directs to rather than simply So, I went – very reluctantly – into my site’s database tables. However, the omission of www was not the issue.

    The siteurl field contained the www. However, perhaps in a fit of narcissism, it seems that WP made the siteurl during installation – instead of

    So, I changed the siteurl value to This seems to have done the trick.

    1. Log in to you cpanel or vdeck.
    2. Access your databases (for mine, this was through myphpAdmin).
    3. Find the wp_options database.
    4. Locate the siteurl option_name.
    5. Then find the option_value field for the siteurl.
    6. Make sure that the field contains the full URL for the address where your site resides (eme.g.em, [Mine read:, which was incorrect.]
    7. Save the changes.

    I hope this helps those of you who have tried everything else posted here without success.

    Good luck.

  • The topic ‘Enable Referrers Possible Solution’ is closed to new replies.