Support » Plugin: Quotes for WooCommerce » “Enable Quotes” setting not working for me

  • Resolved Kevin Pryce

    (@kpry44)


    Hey there,

    On a fresh WordPress installation, I choose the “Enable Quotes” option in plugin settings, but all products still show prices, have the add-to-cart button, and attempt to collect payment. It is as if the setting is not doing anything.

    The plugin does work if I manually enable each individual product.

    Looking for assistance – please and thanks.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Pinal Shah

    (@pinalshah)

    Hi @kpry44,

    It seems the settings are not being updated for the products when you save the global settings. Can you please let me know the number of products present on the site.

    Also, can you please check the DB and see if post meta records are being created for the products (with status published and draft) with the below meta keys when you update the global settings:

    1. qwc_enable_quotes
    2. qwc_display_prices

    Pinal

    Thread Starter Kevin Pryce

    (@kpry44)

    Hi @pinalshah,

    I have a total of 4 products. I am using a fresh install in localhost to test.

    I can see the meta keys in the DB, but they have empty values.

    thanks!

    Plugin Author Pinal Shah

    (@pinalshah)

    Hi @kpry44,

    That’s strange. Do they remain blanks even when you enable the checkbox and save it?

    I tried replicating the issue on a fresh installation on my local and was unable to replicate the same.

    Can you kindly upload this on a staging/dev site and send me the access details so I can look into the issue?

    Please send the WordPress admin access and the FTP access details on pinalj1612 at gmail dot com.

    Pinal

    Thread Starter Kevin Pryce

    (@kpry44)

    Yes the blanks remained blank after enabling the checkbox.

    I deleted and re-installed the plugin and it appears to be functioning as expected.

    Thanks for the help.

    http://biomedwaste.com

    Thread Starter Kevin Pryce

    (@kpry44)

    I have an update on this symptom.

    Any products that already exist in the database when the plugin is installed have quotes enabled. Any new products you add afterwards do not.

    See this new product I added. Notice that it shows “add to cart” but all my other products show “request quote”.

    https://biomedwaste.com/product/needle-disposal-unit/

    Thanks.

    Plugin Author Pinal Shah

    (@pinalshah)

    Hi @kpry44,

    Yes, when you modify the setting, it updates all the existing products. However, for any products that are created after the setting was modified, the setting will not flow through automatically.

    When adding the new product, you will have to manually enable/disable the setting as needed.

    In a scenario where you add multiple products after modifying the setting, it might be a better idea to update the global setting again.

    Pinal

    Thread Starter Kevin Pryce

    (@kpry44)

    Thank for the reply.

    I understand your explanation but am wondering why this is the case? From my perspective, if I enable the “global” setting, it should take effect globally.

    Can you help me understand the reason why new products don’t respect the global setting please?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘“Enable Quotes” setting not working for me’ is closed to new replies.