WordPress.org

Support

Support » Themes and Templates » Enable Paged Navigation

Enable Paged Navigation

  • The theme that I’m using 2813 WordPress Theme does not have paged navigation enabled in it. I tried using WP PageNavi plugin but that too didn’t help. In theloop.php the relevant template tag is available:

    /* Insert Paged Navigation */ if (!is_single()) { include (TEMPLATEPATH . '/navigation.php'); } ?>

    Then I opened the home.php and added the following at the end:

    <div class = 'navigation'>
    		<?php include('navigation.php'); ?>

    Still navigation doesn’t display.

    Would appreciate any help on this. Thanks.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Somebody please help, at least a hint.

    It seems like the last time I used a home.php template it wouldn’t navigate pages. I don’t think it’s a theme issue. Try appending /page/2/ at the end of your root URL. If it shows the home page again, then that’s the problem.

    There has been a problem with “outside the norm” loops and paged navs. I don’t know if that’s the problem here, but a search will turn up a lot of posts about paged nav problems….

    jonlandrum,m i don’t think the problem exists with all theme3s home.php. WP.com also has the same 2813 theme but there the paged navigation worked fine. Wonder how they did it?

    Also this theme also uses home.php and works.

    And yes, the /page/2 thingy doesn’t work.

    vkaryl, I found lot of stuff on pag nav probs but nothing thjat would solve me problem.

    wp.com is run on wpmu, so things may be very different….

    And I don’t think WPmu is using a home.php file. I’m pretty sure it uses index.php, which pages just fine. I never found any way around it, but that was about a year ago. There may be a plugin or something these days.

    I honestly don’t know, since I never do the “home.php” thing – if I want something like that I do it the old-fashioned way….

    I got pagging to work by deleting the home.php file. it works fine but now i have changed my theme itself. But als this one also uses home.php and paging doesn’t work in this one as well 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Enable Paged Navigation’ is closed to new replies.