WordPress.org

Support

Support » Plugins and Hacks » Front-end Editor for WordPress » [Resolved] Enable only for admin?

[Resolved] Enable only for admin?

  • Wow, this plugin is really impressive. Even has tables!

    I’d like to test this out on my live site real well before I turn contributors loose with it.

    Is there a way I can enable it only for the admin? While letting other users continue the built in wordpress way for the the time being?

    I tried doing this in wp-front-end-editor.php:

    if( current_user_can(‘level_10’) ){
    WP_Front_End_Editor::instance();
    }

    But that just causes an error.

    I have noticed something in testing so far. When a message comes up from wordpress on the front end editor, such as “There is an autosave of this post that is more recent than the version below. View the autosave”, there is not a way to dismiss it. It’s in the way. Is this a known issue, or maybe just something related to my (aging) theme?

    Thanks for the work that’s going into this plugin – it’s great!

    Chris

    https://wordpress.org/plugins/wp-front-end-editor/

Viewing 1 replies (of 1 total)
  • Plugin Author Ella van Dorpe

    @iseulde

    Thanks for trying it out!

    This plugin is still in an experimental stage, though it’s pretty stable to use. It’s not really possible to change its behaviour much because we might change this.

    The autosave notice will be dismissible, don’t worry.

Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] Enable only for admin?’ is closed to new replies.
Skip to toolbar