Support » Plugin: iThemes Security (formerly Better WP Security) » Enable Hide Backend & Google authenticator

  • Resolved PE-Pernet

    (@pe-pernet)


    Hi,
    I use Google authenticator to secure my login but, because I’m facing a lot of lockout due to bad login, I’ve try to enable “Hide backend” feature.
    It works… but I’m no longer requested to enter my Google authenticator code !
    Yo be honest I was so happy not to be locked out that I disable this feature before something went wrong !
    Why do I land on different login page when I activate this option ?

    https://wordpress.org/plugins/better-wp-security/

Viewing 15 replies - 1 through 15 (of 18 total)
  • Same problem, when hide backend is enabled the google auth plugin not work at all…..

    I had the same issue with Google Authenticator, though I wasn’t able to log in at all. I had to rename the plugin folder to break it so I could.

    For me even with G Auth enabled i able to login normally only with user and password…. It’s really bad, i really need this fixed.

    Agree !
    That would add an additional layer of security to the product.

    4.0.12 up…. G Auth issue continues!

    Same problem!

    4.0.16 up…. Nothing solved!

    4.0.19 … not solved

    Prior to the re-write from Better-WP-Security to iThemes Security, I had both the ‘Hide Backend’ feature of B-WP-S enabled and the Google Authenticator plugin installed and both worked fine. After the re-write to iThemes Security I continue to have the ‘Hide Backend’ feature enabled but now the Google Authenticator plugin won’t work. It’s a tough choice between choosing which feature I want to work the most. I am very uncomfortable with not having the 2FA of the Google Authenticator plugin working after having it in place for so long.

    I also noticed that iThemes are planning their own 2FA Authentication feature as a pro feature for iThemes Securiy, so maybe they have no incentive to fixing this Google Authenticator bug they have introduced.

    Plugin Author iThemes

    (@ithemes)

    Hey All,

    This is being addressed. Could you please update to v4.0.21 and see if that helps?

    Thanks,

    Gerroald

    Hi iThemes, i’ve updated to 4.0.21, nothing changed…. The G Auth continues not working….

    Thanks in advance.

    PS: For information, i’m using the WP Google Authenticator v1.0.7 plugin, but i already tested with Google Authenticator plugin (other plugin that works in version 3.6.6) and this plugin not works too.

    I have updated to iThemes Security 4.0.21 and I am using Google Authenticator 0.47 (http://wordpress.org/plugins/google-authenticator/) on WordPress 3.8.2. The problem still exits, the Google Authenticator plugin is still broken.

    Are some some specific settings in iThemes Security we should toggle on or of? Please advice.

    The update didn’t help for me.

    Really need this fix. I downgraded for now.
    Google Auth also important for me.

    It looks like your 4.0.23 update of iThemes Security has fixed the problem with the 2FA Google Authenticator plugin. Mine is back working again. Thanks for this fix and I apologise for suggesting above that you may have no incentive to fix this as you plan to introduce 2FA as a Pro feature for iThemes Security, you have proved me wrong and I am glad so.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Enable Hide Backend & Google authenticator’ is closed to new replies.