Support » Plugin: WP Super Cache » Enable gzip compression

  • wpfan1000

    (@wpfan1000)


    Hi,

    I checked my site in gtmetrix and tools.pingdom.

    They both gave me a lower score and load time because I did not have gzip enabled.

    So I went to my hosting company settings and enabled gzip compression.

    Then my scores and load time improved on gtmetrix and tools.pingdom.

    But then I saw a warning in WP Super Cache:

    Zlib Output Compression Enabled!

    PHP is compressing the data sent to the visitors of your site. Disabling this is recommended as the plugin caches the compressed output once instead of compressing the same page over and over again. Also see #21 in the Troubleshooting section. See this page for instructions on modifying your php.ini.

    So I turned off gzip compression on my hosting and I got back the lower score on gtmetrix and tools.pingdom that I was not using gzip compression.

    So the plugin is telling me not to use gzip compression which leads to lower scores.

    So I am not sure what to do……

    Please help.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Saša

    (@stodorovic)

    Regarding that PHP already handles compression, the easiest way is disabling compression in WPSC (uncheck “Compress pages so they’re served more quickly to visitors.“).

    I didn’t test all possible cases when ‘zlib.output_compression‘ is On, but it should work (even you see warnings on WPSC dashboard). If you can create custom/edit php.ini (or .user.ini on some hostings) then you could try to set ‘zlib.output_compression‘ to Off (which disable compression “on the fly” in PHP).

    wpfan1000

    (@wpfan1000)

    Hi,
    Thank you for your quick response.

    Because you indicate that it should be ok to have both on, I think I will keep:

    Hosting > zlib.output_compression ON
    WPSC > Compress pages so they’re served more quickly to visitors ON

    Because that seems to give me the highest rankings in pingdom, gtmetrix and google page speed.

    I tried to do some testing to see which combination was best, ie one or both on.

    And I ran into an issue. I created a separate post for this:
    https://wordpress.org/support/topic/cannot-disable-compress-pages-so-theyre-served-more-quickly-to-visitors/

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Enable gzip compression’ is closed to new replies.