Support » Plugin: WP Job Manager » Enable comments on listings

  • Resolved allisontavora

    (@allisontavora)


    Hello!

    I’m not sure that this is a WordPress or Plugin issue, but to enable commenting on a listing I have to do this manually, in the edit of each listing, going to the field “comments” enabling this function. It turns out that I already checked the settings in WordPress (Discussion) and there is nothing that prevents comments, because they are active. It’s not a problem with user permissions, as I’ve checked that too. As for the template the site, I saw nothing that would block the comments as well.

    Any idea what that might be? I want the “comments” field to be enabled by default for all listings, automatically.

    Thanks in advance for your attention and I look forward to your help.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor Cena

    (@cena)

    Hi there,

    We have a snippet you can use, here: https://wpjobmanager.com/customization-snippets/#enableComments

    We recommend you add the snippet to a plugin like Code Snippets: https://wordpress.org/plugins/code-snippets (rather than functions.php).

    Best,

    Hi @cena

    Hi

    Thanks for your reply though, I’m still in trouble;)

    Using what you indicated, I have the following problem:

    When I add this code the “comments” field still does not appear, even after publishing new listings:

    // Add comment support to the job listing post type – you’ll need to enable the comments for old listings manually
    add_filter (‘register_post_type_job_listing’, ‘register_post_type_job_listing_enable_comments’);

    function register_post_type_job_listing_enable_comments ($ post_type) {
    $ post_type [‘supports’] [] = ‘comments’;
    return $ post_type;
    }

    When I add the code below, the “comments” field appears when the user is going to publish the listing. The field “comments” is there being required, forcing the user to comment something so that the listing is published.

    // Make comments open by default for new job listings
    add_filter (‘submit_job_form_save_job_data’, ‘custom_submit_job_form_save_job_data’);

    function custom_submit_job_form_save_job_data ($ job_data) {
    $ job_data [‘comment_status’] = ‘open’;
    return $ job_data;
    }

    Can you give me a hint how to solve this?

    Thank you.

    Print: https://imgur.com/a/ayxLObn

    • This reply was modified 1 year, 1 month ago by  allisontavora.
    Plugin Contributor Cena

    (@cena)

    Hi Allison,

    As the page notes, all these customization snippets are for informational purposes only. Our support policy does not include assistance with customizations. We can not assist with modifying or debugging code from these snippets.

    That said, we DO want to make sure they’re working correctly, so I tested the snippet on my own site. It does work for new listings correctly (as indicated in the snippet, you’ll need to manually enable comments for old listings), but it appears dependent on your theme. The comment box did not show up in Jobify, but it does show up in Twenty Sixteen, for example.

    If you’ve tested the snippet by creating a new listing and the comment box is not showing up, try switching to a default like Twenty Sixteen. If it appears there, you’ll know it’s an issue with your theme, and you’ll need to contact that developer for further help getting the comment box integrated correctly.

    Best,
    Cena

    @cena

    So the problem might be on the site template?

    If it worked out well with you, it should have worked for me too.

    Okay, I’ll check that out.

    Thank you very much.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Enable comments on listings’ is closed to new replies.