Support » Plugin: WP eCommerce » EN_en.php languages file not being used?

  • Resolved Andrew Hewatt

    (@andrewhewatt)


    Not sure if these are supported anymore but we’ve been using WPeC for years and have a wpsc-languages folder with EN_en.php along with other .po language files in it. We’d like to update the language in EN_en.php and have it kept when we update the plugin but it seems it’s not even used? We’re trying to update the ‘TXT_WPSC_YOU_JUST_ADDED’ variable to say ‘You just added “[product_name]” to your quote.’ instead of “… to your cart”.

    Is this possible?

    Currently we have to edit the /wpsc-components/theme-engine-v1/helpers/ajax.php file each time we update the WP eCommerce plugin.

    Does anyone have thoughts or advice on this?

    Thanks for the help,
    – Andrew

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Mihai Joldis

    (@misulicus)

    Hey @andrewhewatt
    You could use this simple plugin to transalte that string: https://wordpress.org/plugins/say-what/

    That file is no longer used and its there just for back compat with the old 3.7 versions which hopefully no one uses now.

    Hey @misulicus, thanks for the info and suggestion.
    We’d prefer not to use another plugin but will check this one out.

    Are you saying that the recommended place to edit this string is indeed in the /wpsc-components/theme-engine-v1/helpers/ajax.php file? Or is there a way to update it and have that change persist after an upgrade of WP eCommerce?

    Thanks for your help.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.